Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Como atualizar as DLL do Protheus Varejo

time.png Tempo aproximado para leitura: 00:03:00 min

 

Dúvida
MP - SIGALOJA - Como atualizar as DLL do Protheus Varejo


Ambiente
SIGALOJA/SIGAFRT - Todas as versões homologadas

 

Causa

Ao acessar algumas rotinas e \ou módulos do Protheus pode ser apresentada as seguintes mensagem:

"Erro ao abrir SIGALOJA.DLL"

Esta mensagem ocorrem devido a falta dos arquivos de DLL na pasta SmartClient ou WebAgent.

 

Solução em vídeo:

 


Solução (leitura):

01. VALIDAÇÃO DA VERSÃO DO SMARTCLIENT OU WEBAGENT

 

Para validar qual a versão do seu smartclient, acesse as propriedades do atalho e adicione um -T ao final do destino.

 

Exemplo: C:\Smartclient64\smartclient.exe -T

 

 

Após adicionar o comando no atalho, aplique e salve as alterações e execute o atalho modificado. 

 

Será apresentada uma das mensagens abaixo que informa qual a versão do seu SmartClient.

 

Resultado do Smartclient 64 bits:

 

Resultado do Smartclient 32 bits:

 

⚠ Atenção!

Remova o -T da propriedade do atalho para acessar o ambiente novamente.

 

No WebAgent, você deve criar um novo atalho (você pode copiar o atalho atual e colar na área de trabalho do Windows), depois acesse as propriedades do atalho em questão e adicione o comando --version ao final do destino.

Exemplo: C:\Users\usuario\AppData\Local\Programs\web-agent\web-agent.exe --version

 

 

Após adicionar o comando no atalho, aplique e salve as alterações e execute o atalho modificado. 

 

Será apresentada uma das mensagens abaixo que informa qual a versão do seu WebAgent.

 

Resultado do WebAgent 64 bits:

 

Resultado do WebAgent 32 bits:

 

 

 IMPORTANTE!

Para uso de equipamentos no módulo do SIGALOJA é necessário o uso do SmartClient ou WebAgent na versão 32 bits.

 

 

02. DOWNLOAD DE ARTEFATOS 

Após a identificação da versão do seu SmartClient ou WebAgent, baixe as DLLs do Protheus correspondentes a sua versão abaixo:

 

Versão Download
DLL versão 32 bits Clique aqui
DLL versão 64 bits Clique aqui

 

OBS: Os arquivos contém a DLL 0.3.145.18 do SIGALOJA

⚠ Atenção!

Pode ocorrer do navegador bloquear o download por conter um conteúdo de DLL no arquivo. Basta acessar o histórico de downloads do navegador e permitir com que o arquivo seja baixado.

03. EXTRAÇÃO DAS DLLS

Baixando as DLLs correspondentes a versão do seu sistema, extraia os arquivos e cole dentro da pasta do SmartClient ou WebAgent.

 

Exemplo de caminho do SmartClient: C:\TOTVS\tec\smartclient\smartclient

Sequência (Sequence) 02 (1).gif

 

Exemplo de caminho do WebAgent: C:\Users\usuario\AppData\Local\Programs\web-agent

WEBAGENT (1).gif

 

04. ACESSO AO SISTEMA

Realize o teste acessando o sistema com um usuário caixa.

 

Caso ao acessar o módulo do SIGALOJA apresente a mensagem "Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscalacesse a documentação abaixo:

 

 

MP - SIGALOJA - Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscal.

Esse artigo foi útil?
Usuários que acharam isso útil: 6 de 7

2 Comentários

  • Avatar
    Flavio Lourenço Gori Fernandes

    Essa pagina precisa ser atualizada com mais frequencia, esse donwload vem com varias dll muito antigas (principalmente ao TEF da totvs) que acabam gerando ainda mais problema aos clientes. 

    2
    Ações de comentário Permalink
  • Avatar
    Thiago Augustus de Souza Oliveira

    Essas Dll's estao antigas precisa ser atualizada.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _