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MP - SIGALOJA - Como atualizar as DLL do Protheus Varejo

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Dúvida
MP - SIGALOJA - Como atualizar as DLL do Protheus Varejo


Ambiente
SIGALOJA/SIGAFRT - Todas as versões homologadas

 

Causa

Ao acessar algumas rotinas e \ou módulos do Protheus pode ser apresentada as seguintes mensagem:

"Erro ao abrir SIGALOJA.DLL"

Esta mensagem ocorrem devido a falta dos arquivos de DLL na pasta SmartClient ou WebAgent.

 

Solução em vídeo:

 


Solução (leitura):

01. VALIDAÇÃO DA VERSÃO DO SMARTCLIENT OU WEBAGENT

 

Para validar qual a versão do seu smartclient, acesse as propriedades do atalho e adicione um -T ao final do destino.

 

Exemplo: C:\Smartclient64\smartclient.exe -T

 

 

Após adicionar o comando no atalho, aplique e salve as alterações e execute o atalho modificado. 

 

Será apresentada uma das mensagens abaixo que informa qual a versão do seu SmartClient.

 

Resultado do Smartclient 64 bits:

 

Resultado do Smartclient 32 bits:

 

⚠ Atenção!

Remova o -T da propriedade do atalho para acessar o ambiente novamente.

 

No WebAgent, você deve criar um novo atalho (você pode copiar o atalho atual e colar na área de trabalho do Windows), depois acesse as propriedades do atalho em questão e adicione o comando --version ao final do destino.

Exemplo: C:\Users\usuario\AppData\Local\Programs\web-agent\web-agent.exe --version

 

 

Após adicionar o comando no atalho, aplique e salve as alterações e execute o atalho modificado. 

 

Será apresentada uma das mensagens abaixo que informa qual a versão do seu WebAgent.

 

Resultado do WebAgent 64 bits:

 

Resultado do WebAgent 32 bits:

 

 

 IMPORTANTE!

Para uso de equipamentos no módulo do SIGALOJA é necessário o uso do SmartClient ou WebAgent na versão 32 bits.

 

 

02. DOWNLOAD DE ARTEFATOS 

Após a identificação da versão do seu SmartClient ou WebAgent, baixe as DLLs do Protheus correspondentes a sua versão abaixo:

 

Versão Download
DLL versão 32 bits Clique aqui
DLL versão 64 bits Clique aqui

 

⚠ Atenção!

Pode ocorrer do navegador bloquear o download por conter um conteúdo de DLL no arquivo. Basta acessar o histórico de downloads do navegador e permitir com que o arquivo seja baixado.

03. EXTRAÇÃO DAS DLLS

Baixando as DLLs correspondentes a versão do seu sistema, extraia os arquivos e cole dentro da pasta do SmartClient ou WebAgent.

 

Exemplo de caminho do SmartClient: C:\TOTVS\tec\smartclient\smartclient

Sequência (Sequence) 02 (1).gif

 

Exemplo de caminho do WebAgent: C:\Users\usuario\AppData\Local\Programs\web-agent

WEBAGENT (1).gif

 

04. ACESSO AO SISTEMA

Realize o teste acessando o sistema com um usuário caixa.

 

Caso ao acessar o módulo do SIGALOJA apresente a mensagem "Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscalacesse a documentação abaixo:

 

 

MP - SIGALOJA - Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscal.

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