Ocorrência
No Módulo Controle de Lojas, ao acessar a rotina Venda Assistida é apresentado erro de Incompatibilidade de DLL.
Ambiente
Microsiga Protheus - SIGALOJA - SIGAFRT - TOTVS PDV- Aplicável a partir da versão 12.1.23.
Causa
Falta de arquivos DLL/SmartClient incorreto.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. De acordo com o SmartClient (32 ou 64 bits), baixe o pacote de DLL recomendado conforme orientação:
Para o SmartClient de 32 bits: |
Acesse seu repositório de objetos (MP - CFG - Como gerar arquivo com Inspetor de Objetos do ambiente), verifique a data do fonte LOJXECF e baixe o pacote de DLL recomendado:
|
Para o SmartClient de 64 bits: |
Saiba Mais: MP - SIGALOJA - Homologação do SmartClient de 64 bits |
Importante: A versão das DLL's e do SmartClient deve ser compatível para leitura. Caso utilize o SmartClient de 32 bits, aplique as DLL's de 32 bits no ambiente, assim como para o SmartClient de 64 bits devem ser aplicadas as DLL's de 64 bits. (Para atualização dos binários, verifique o artigo: MP - SIGALOJA - Atualização dos Binários).
2. Após baixar o pacote recomendado, descompacte-o dentro da pasta SmartClient onde ocorre a inconsistência e verifique se o erro de incompatibilidade é solucionado.
Saiba Mais
MP - SIGALOJA - Incompatibilidade da versão entre a DLL Fiscal e o RPO do Protheus
MP - SIGALOJA - A DLL: MP2032.DLL e/ou SIUSBXP.DLL não foi encontrado
MP - SIGALOJA - Erro Impossível ler DLL/SO Não foi possível carregar a DLL/SO?
MP - SIGALOJA - Atualização de DLL
Vídeos How To:
Abaixo seguem os pacotes de DLL's (sigaloja.dll, totvsapi.dll, autocom.dll, advplce.dll, zlib.dll) para serem baixados:
0 Comentários