Dúvida
Como atualizar as DLL do Protheus Varejo ?
Ambiente
Microsiga Protheus - SIGALOJA - SIGAFRT - TOTVS PDV- Aplicável a partir da versão 12.1.23.
Causa
Ao acessar algumas rotinas e\ou módulos do Protheus pode ser apresentada as seguintes mensagem:
Erro ao abrir SIGALOJA
Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscal
Estas mensagens podem ocorrer devido a falta dos arquivos de DLL na pasta SmartClient ou diferença entre a versão das DLLs presentes na pasta com a esperada pelos fontes do RPO
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Configure o atalho do Smartclient com o parâmetro -T e execute o atalho:
Será apresentada uma das mensagens abaixo que inforam se o Smartclient utilizado é 32 ou 64 bits
Resultado do Smartclient 64 bits:
Resultado do Smartclient 32 bits:
2. Após identificar se o Smartclient utilizado é 32 ou 64 bits baixe o pacote respectivo pacote abaixo:
Pacote de DLL Sigaloja 32 bits
Pacote de DLL Sigaloja 64 bits
3. Em seguida feche o Smartclient, retire o parâmetro -T adicionado no item 1 e extraia o pacote de DLLs na pasta Smartclient.
4. Realize o teste de acesso ao Smartclient e verifique se soluciona o problema.
ATENÇÃO! Somente se ao abrir o sistema for apresentada a mensagem Existe incompatibilidades entre a versão do Repositório Protheus e a DLL Fiscal, realize os demais passos:
5. Será apresentada a primeira mensagem informado a VERSÃO ATUAL DA SUA DLL
2. Em seguida será apresentada a mensagem mostrando (em destaque) a versão esperada pelo RPO
3. Baixe a DLL solicitada por seu ambiente através dos links abaixo:
Saiba Mais
MP - SIGALOJA - Incompatibilidade da versão entre a DLL Fiscal e o RPO do Protheus
MP - SIGALOJA - A DLL: MP2032.DLL e/ou SIUSBXP.DLL não foi encontrado
MP - SIGALOJA - Erro Impossível ler DLL/SO Não foi possível carregar a DLL/SO?
MP - SIGALOJA - Atualização de DLL
Vídeos How To:
1 Comentários