Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Comunicado Ciclo de Vida de Software - TOTVS Linha Protheus

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao acessar os relatórios MATR (TReports), o Protheus apresenta a mensagem "Comunicado Ciclo de Vida de Software - TOTVS Linha Protheus"

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Protheus Release 12.1.2510 ou Superior.

Causa 
Com a missão de aumentar a capacidade competitiva de seus clientes, a TOTVS vem constantemente trabalhando na evolução funcional e tecnológica de seus produtos e, por esse motivo, comunicamos que este relatório está descontinuado. 

O código fonte deste relatório está disponível para download no Portal do Cliente TOTVS (utilizar o campo Categoria com a opção Programa Fonte de Relatório). Indicamos a utilização da nova ferramenta para extração de dados do ERP, o Smart View.

Solução
Informamos conforme o comunicado Oficial da TOTVS, os relatórios TReports (relatórios MATR) foram descontinuados em 31/10/2024 e o seu uso foi bloqueado definitivamente no release 12.1.2510 a partir de 01/07/2026. Portanto, não é mais possível utilizá-los na plataforma padrão.
 
Para a extração de dados do ERP, indicamos a utilização da nova ferramenta oficial, o Smart View.
 
Para lhe auxiliar na transição, segue links de apoio abaixo:

Documentação de configuração:
Cross Segmento - Backoffice (Linha Protheus) - SMARTVIEW - Como efetuar a configuração para utilizar o Smart View?
 
Como configurar o Smart View: 
How To: Configuração do Smart View - Parte 1/3 (Rest + Instalação)
How To: Configuração do Smart View - Parte 2/3 (Dados de Conexão)
How To: Configuração do Smart View - Parte 3/3 (Conectores + Token Protheus)

Relação de relatórios e visualizações disponíveis:
Ciclo de Vida de Software - Relatórios Substituídos


Os códigos fontes dos relatórios antigos estão disponíveis para download no Portal do Cliente TOTVS (utilizando o campo Categoria com a opção Programa Fonte de Relatório). Eles podem ser convertidos em User Function e adequados conforme a sua necessidade.

Fontes de relatórios Estoque para alteração ou customização fora do padrão


Importante: O suporte padrão da TOTVS não auxilia na adaptação dos relatórios descontinuados como User Function. Caso sua empresa opte por não utilizar o SmartView e necessite de apoio técnico para realizar essa conversão e mapeamento, será necessária a contratação de um analista in loco.

Saiba mais:
Com os relatórios MATR* descontinuados, onde posso consultar os dados?

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _