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Ocorrência
Ao tentar realizar a inclusão ou atualização de um novo cliente, o sistema apresenta uma mensagem informando que o CNPJ já consta como cadastrado. No entanto, ao realizar a pesquisa pelo número do documento na listagem padrão, o registro não é retornado.
Ambiente
Cross Segmentos - TOTVS CRM Gestão de Clientes - Contas - Todas as versões
Causa
Este comportamento ocorre quando o CNPJ em questão já está vinculado a um registro de Lead ou Cliente no sistema. Como a busca simples na tela de Contas pode estar filtrando apenas registros de clientes ativos, o dado não aparece nos resultados iniciais. Outro fator que contribui para essa dificuldade de localização é a ausência de configuração de máscara ou validação padrão de CNPJ, o que pode permitir que o registro exista com uma formatação diferente da pesquisada.
Solução
Para validar, siga estes passos:
1. No módulo de Contas, acesse a tela de listagem de registros, seja em Leads ou Clientes.
2. Utilize o recurso de Filtro Avançado, clicando no botão representado por um ícone de funil sobre a listagem.
3. Realize a pesquisa pelo CNPJ desejado para confirmar se o registro consta na base como Lead ou outro status de conta.
4. Caso o registro seja localizado no módulo de Leads, realize os ajustes ou a conversão necessária.
5. Como ação preventiva, recomenda-se ativar a máscara e a validação padrão de CNPJ nas configurações de documentos de identificação para evitar duplicidades por erros de preenchimento.
Saiba mais
Filtro avançado
Aplicar máscara em um documento de identificação
Formato de CNPJ alfanumérico
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