Tempo aproximado para leitura: 00:04:30 min
Ocorrência
Ao acessar o Meu RH, é apresentado a mensagem de erro: "500 - One or more errors occurred" ou "500 -Um ou mais erros".
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas as versões
Causa
Este erro ocorre devido a problemas de comunicação entre o servidor de Aplicação RM e Portal RM, que podem ser causados por configuração de IP ou Porta incorretas.
Solução
Para solucionar essa ocorrência, realize as seguintes validações:
1. Verifique se as Portas dos serviços Host utilizadas pelo Meu RH estão reservadas corretamente:
Comandos Relacionados às Reservas de Portas:
-
Reserva:
netsh http add urlacl url=http://+:Porta/ user=NetworkService -
Listar Todas as Portas Reservadas:
netsh http show urlacl -
Remover Reserva:
netsh http delete urlacl url=http://+:Porta/
Pontos de atenção:
- Reservar Portas WCF: As portas do WCF devem ser reservadas apenas quando houver o uso de certificado no host. Se o certificado estiver no IIS, execute o comando para listar as portas reservadas e remova as portas relacionadas à WCF.
- Reservar Todas as Portas WebAPI: Certifique-se de reservar todas as portas WebAPI utilizadas pelos Hosts dos "Servidores de Aplicação" e pelo "Servidor do Portal".
-
Reservar a Porta em HTTP ou HTTPS?
Caso o certificado esteja vinculado ao IIS, a reserva de todas as portas deverá ser feita em HTTP. No entanto, se o certificado estiver vinculado diretamente ao Host, a reserva das portas deverá ser realizada em HTTPS. -
Saúde do Ambiente: Todas as portas WebAPI utilizadas pelo Meu RH, precisam retornar "Serviço Ok" nos testes healthcheck. Atualize o navegador diversas vezes para que a validação seja realizada em todas as portas. Utilize os seguintes links para validação:
http://IP_SERVIDOR_HOST_MEURH:PORTA_WEBAPI/api/rh/v1/services/healthcheck
Exemplo:http://10.173.16.246:8051/api/rh/v1/services/healthcheckPara teste direto do servidor do portal:
http://localhost/framehtml/rm/api/rest/new/services/healthcheck
Caso as portas já estejam reservadas corretamente e ainda seja retornado o erro “500 - Um ou mais erros” em uma porta específica, siga os passos abaixo para verificar e corrigir a situação.
2. Verifique no servidor se existem bloqueios de infraestrutura internos nesta porta específica. Uma forma rápida de realizar esse teste é utilizando o PowerShell, executando o seguinte comando:
Test-NetConnection -ComputerName IP_DO_SERVIDOR -Port XXXX
Se o resultado TcpTestSucceeded for False, isso indica que o problema está relacionado à rede ou à infraestrutura (por exemplo: bloqueio de firewall ou porta em uso por outra aplicação interna).
3. Caso seja retornado True no resultado TcpTestSucceeded e o erro persista na validação do healthcheck, o problema pode estar relacionado à comunicação entre o IP e o DNS do servidor.
Para forçar a comunicação utilizando apenas o IP, realize os seguintes ajustes nos arquivos de configuração:
3.1. Alteração do arquivo Web.config
No diretório C:\TOTVS\CorporeRM\FrameHTML, edite o arquivo "Web.config". Dentro da tag appSettings, altere o valor da tag "Host" para o IP do servidor de aplicação do RM:
3.2. Alteração do arquivo RM.Host.Service
No diretório C:\TOTVS\CorporeRM\RM.Net, edite os arquivos "RM.Host.exe.config" e "RM.Host.Service.exe". Dentro da tag appSettings, verifique se já existe a tag "Host" e altere o valor para o IP do servidor de aplicação. Caso não tenha esta tag, copie ela do arquivo Web.config para incluir:
Observação: Caso utilize a tag "ServicesHostName" nos arquivos Host, deverá alterar o valor dela também para o IP do servidor de aplicação do RM.
Importante: Sempre que realizar uma alteração de reserva de porta ou em arquivos configs, reinicie os Hosts e o serviço IIS.
Saiba mais:
RH - RM - Meu RH - Erro ao logar no APP Meu RH, Sistema indisponível no momento
0 Comentários