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Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - Help: TITNAOXADO ao cancelar a baixa do título

time.pngTempo aproximado para leitura: 00:05 min

Ocorrência
Ao realizar o cancelamento da baixa do título na rotina FINA750/ FINA740 ou na rotina FINA080/FINA070 ocorre o HelpTITNAOXADO 

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Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - Todas as versões.

Causa 
Esse incidente ocorre, pois possui divergência entre os tamanhos de campos nas tabelas SE2 e SE5
Exemplo: Na tabela SX3 (dicionário) o campo E2_PARCELA está com tamanho = 2 e na E5_PARCELA está com tamanho = 3
mceclip0.png

Ou 

O tamanho dos campos da chave de identificação do título está diferente no banco de dados.

Exemplo:

Na imagem abaixo podemos ver que na tabela de dicionário SX3 o tamanho do campo parcela tem tamanho 2

 

Na imagem abaixo podemos abrir o banco de dados e consultar para ver se o tamanho do campo parcela na SE2 possui o mesmo tamanho de campo.

Devemos abrir a tabela SE2 ao invés da SX3

Caso tenha diferença de tamanho, irá apresentar o problema de relacionamento entre a tabela SE1/SE2 e a tabela SE5 e, ao tentar estornar, irá apresentar o help TITNAOXADO. 


Essa consulta deverá ser feita entre as tabelas SE1/SE2 e SE5 referentes às chaves de identificação do título, que são:

filial + prefixo + número + parcela + fornecedor + loja 

 

Solução
No configurador existe o grupo de campos Parcela, no padrão do sistema, os tamanhos de campos deve estar iguais no dicionário e banco de dados. Solicite ao seu executivo de soluções de negócio (ESN) a visita de um analista in loco para avaliar e corrigir a estrutura do seu ambiente. 
A chave de identificação do título é composta pelos campos FILIAL + PREFIXO + NUMERO + PARCELA + FORNECEDOR + LOJA. Temos esta chave nas tabelas (SE1/SE2/SE5).
Se "o tamanho" de algum desses campos estiver diferente entre essas tabelas, o incidente será apresentado.
Outro problema que pode gerar o help seria a sequência de baixa no campo E5_SEQ,  caso a próxima baixa esteja com a mesma sequência da primeira, o help também é apresentado. Toda vez que realiza uma baixa e um cancelamento, o sistema grava uma sequência conforme exemplo abaixo:



 

 

Importante

Os parâmetros MV_BX10925 e MV_BR10925 não devem ser alterados, uma vez que, no momento da implantação do Protheus, foi definido como a empresa irá tratar o imposto.

A alteração dos parâmetros mencionados resultará na exibição da mensagem de erro, pois modifica o comportamento do sistema na geração dos impostos.


A manipulação da base de dados não é contemplada em nosso escopo de atendimento de Suporte Técnico; esse tipo de procedimento é efetuado apenas por analista in loco. Confira nosso Escopo -  https://tdn.totvs.com/pages/releaseview.action?pageId=547876496
 

 

Como consultar o tamanho de campos no banco de dados + E5_SEQ

 

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Usuários que acharam isso útil: 1 de 4

4 Comentários

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    FABIO MELLO DE CARVALHO

    A chave de identificação do título é filial + prefixo + número + parcela + fornecedor + loja.Está chave possui tanto na tabela SE2 / SE1 como na tabela SE5.

    Então se "o tamanho" de algum desses campos estiverem diferente entre a SE1 / SE2 e a tabela SE5 vai apresentar o mesmo erro. 

    Caso "o conteúdo" que estiver no campo também estiver diferente entre a SE1 / SE2 e a tabela SE5 vai  apresentar o mesmo erro.Pois o sistema deixará de amarrar as tabelas entre si.

    -1
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    THIAGO IURATO

    O Help também é apresentado quando o título que está sendo cancelado faz parte de uma Fatura.

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    Leonardo Canto Aliberte

    Essa mensagem, também, apareceu quando estava tentando cancelar uma baixa, mas na verdade era uma compensação.

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    Ailton Ferreira de Souza

    Ao tentar fazer a baixa do título em um período não vigente, ele dá mensagem impeditiva, mas baixa o título internamente, sem registrar efetivamente a linha da baixa. Testado sem customizações e ambiente atualizado. Aberto chamado para o produto.

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