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Framework - Linha RM - Frame - Estamos com dificuldade em comunicar com o host

Framework - Linha RM - Frame - Estamos com dificuldade em comunicar com o host

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Ocorrência
Ao acessar o sistema RM é apresentada a seguinte mensagem de aviso Estamos com dificuldade em comunicar com o Host. Aguarde enquanto tentamos recuperar...



Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM


Causa
Esse incidente ocorre, pois o serviço do host não está operando normalmente, ou seja, encontra-se sem conexão para inicializar a aplicação.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Observação: Em caso de ambiente 3/N camadas, os passos 1, 2 e 5 devem ser realizados no servidor de aplicação e os passos 3 e 4 devem ser realizados na(s) máquina(s) client.


1. Certifique-se de que o serviço do host encontre-se iniciado em UNIDADE:\TOTVS\CorporeRM\RM.Net, aplicativo RM.Host.ServiceManager.exe:




2. Caso haja dificuldade em iniciar o serviço do host, siga as orientações do documento abaixo:

Framework - Linha - RM - Frame - Configurações para iniciar o Host


3. Ainda no diretório UNIDADE:\TOTVS\CorporeRM\RM.Net, filtre a pasta RM.Net por Tipo Arquivo CONFIG e localize o arquivo RM.exe.config: 


4.
 Edite o arquivo e verifique se o atributo value da tag  <add key="Host" value="Nome_do_servidor" />  contém o IP ou nome correto do servidor de aplicação. Salve o arquivo RM.exe.config. 



Observação: Caso esteja com o nome correto, efetue um teste alterando o nome para o IP do servidor de aplicação:



5. 
Reinstale o serviço de host

Framework - Linha RM - Frame - Reinstalar host

 
Importante: Caso utilize ambiente N camadas, certifique-se de que nas máquinas app e client não possuem diretivas de segurança como proxy, firewall, UAC, etc, que podem estar realizando o bloqueio de algumas ferramentas do sistema.

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