Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Estoque está sendo utilizado por outra rotina/processo. Aguarde alguns segundos e tente novamente!

Ocorrência
Ao tentar liberar o pedido de venda na rotina 336  é apresentada a mensagem Estoque está sendo utilizado por outra rotina/processo. Aguarde alguns segundos e tente novamente!


Ambiente
WinThor - Vendas - Aplicável a partir da versão 29


Causa
Esse incidente ocorre devido à alguma inconsistência no banco de dados.


Solução
Para resolver esse problema,  verifique se alguma outra rotina está travando o produto, como por exemplo, as rotinas 118, 316, 336, 1402, 1406, 143220313221306. Caso a mensagem ainda continue aparecendo, solicite que o DBA da empresa, realize os procedimentos abaixo:

1. Acesse a rotina 551-Lock de Banco;

2. Clique o botão Logar;

3. Informe o Usuário, a Senha e clique o botão Logar;

4. Em seguida, finalize a sessão que está travada no banco.

GIF551.gif

 

Importante
Para finalizar as sessões é necessário logar com o usuário SYS ou SYSTEM do banco. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

2 Comentários

  • Avatar
    3461 - -DANIEL LIZO

    Esse erro acontece há mais de um ano e até hoje ainda não descobriram um jeito de identificar qual usuário está segurando o estoque. Todo dia ele ocorre, sendo obrigado a matar todas as sessões 316. Já está na hora de pensarem em alguma melhoria.

    0
    Ações de comentário Permalink
  • Avatar
    Daianny Dias

    Boa tarde Daniel, 

    Pode se olhar na 551 e é por ela que tem que finalizar a sessão.
    Geralmente fica em vermelho ou cinza o q está ocasionando o lock, caso não consiga identificar qual usuário teria que analisar o cenário. Pode ser até do próprio banco de dados mesmo.

    Dúvidas estamos à disposição.

     

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _