Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha RM - Frame - Erro DeleteFile falhou

Framework - Linha RM - Frame - Erro DeleteFile falhou

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao realizar a instalação de patch da Biblioteca ocorre erro:

"C:\totvs\CorporeRM\RM.Net\RM.Lib.dll

Ocorreu um erro ao tentar substituir o arquivo existente:

DeleteFile falhou; código 5.

Access is denied.

Clique em Repetir para tentar novamente, em Ignorar para ignorar este arquivo (não recomendado) ou em Cancelar para cancelar a instalação."


Ambiente
Framework - Linha RM - Frame - Todas as versões do RM.

 

Causa
Esse incidente ocorre, pois a dll já existe e não está sendo possível substituí-la para atualização, por falta de permissão ou pois a mesma está em uso. 

 

Solução
Ao realizar a instalação de patch, o instalador para o serviço do Host, atualiza os arquivos necessários e inicia o serviço novamente.

Para correção da ocorrência, siga os passos abaixo:

  1. Avalie se o usuário que está executando o instalador é administrador da máquina;
  2. Clique com o botão direito sobre o arquivo de instalação e em seguida clique em Executar como Administrador;
  3. Pare o serviço do Host através do aplicativo RM.Host.ServiceManager.exe (UNIDADE:\totvs\CorporeRM\RM.Net) e execute o instalador novamente com a opção (Executar como administrador);
    mceclip1.png

  4. Reinicie a máquina e execute o instalador com a opção (Executar como administrador);
  5. Desinstale a Biblioteca .msi, reinstale a mesma e execute o patch com a opção (Executar como administrador).

Saiba mais
Para mais informações sobre a instalação da Biblioteca RM, consulte o link abaixo:
Framework - Linha RM - Frame - Como instalar a biblioteca RM
Framework - Linha RM - Frame - Como realizar atualização de patches da biblioteca

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _