Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - SPEDFISCAL: erro na inclusão TR2 - TOP Error -19 - Invalid bind parameter size 4096

time.png Tempo aproximado para leitura: 00:05:00min

 Ocorrência
Ao tentar gerar o SPEDFISCAL, o sistema apresenta erro na inclusão TR2: TOP Error -19 - Invalid bind parameter size 4096.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Protheus Release 12.1.2310 ou Superior.

Causa
Este tipo de cenário está comumente relacionado à não configuração correta do ODBC para utilização de bancos PostgreSQL. Abaixo seguem algumas validações para a solução do erro.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
 

  1. Junto à sua equipe de TI verifique se o ambiente em questão utiliza banco PostgreSQL. Isso também é possível validar efetuando a busca do termo "TOTVS DBAccess DB" no erro gerado. Conforme a print abaixo:

     
  2. Verifique a versão do seu banco e a versão do seu ODBC para confirmar se estão de acordo com a documentação abaixo, bem como com a observação na captura de tela.

    https://tdn.totvs.com/display/tec/DBAccess+-+Banco+de+dados 


     
  3. Verifique se a sua configuração do ODBC está de acordo com a documentação abaixo para o seu sistema operacional.

    Windows - Como criar uma fonte de dados ODBC para uso com PostgreSQL 
    LINUX - Como criar uma fonte de dados ODBC para uso com PostgreSQL
     

  4. Verifique também se seu ambiente possui o fonte MATXSPED a partir da versão 04/03/2026, e caso não esteja, aplicar o patch abaixo num ambiente de homologação, conforme sua versão:
    12.1.2310:https://r.totvs.io/p/1241751 ; 
    12.1.2410:https://r.totvs.io/p/1241749 ; 
    12.1.2510:https://r.totvs.io/p/1241750 ;
     

  5. Caso o erro persista após validar todos os passos acima, por favor, nos envie:

    - Qual a versão do  seu Banco Postgres; 
    - Qual a versão do driver está utilizando em seu ODBC;
    - Qual seu sistema Operacional e Prints das configurações do ODBC destacando os pontos informados link do ponto 3
    - Nos envie os dados do seu ambiente em nossa central de diagnósticos, conforme (Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Como enviar dados pela Central de Diagnóstico?), e nos informe o ID da central;
     

 

Saiba mais:

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Bloco K- Conceito e configurações mínimas
Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Guia do Bloco H do SPED Fiscal no Protheus
Clique aqui e veja mais artigos sobre Legais no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _