Ocorrência
Ao tentar acessar o aplicativo My Fluig é apresentado o erro Falha na comunicação.
Por que isso ocorre? Como resolver?
Ambiente
TOTVS Fluig Plataforma - Configurações técnicas – A partir da versão 1.6.0
Causa
Essa mensagem pode ser apresentada por diversos motivos, por isso listamos neste artigo as causas mais comuns e suas respectivas soluções.
Solução
Efetue as verificações abaixo:
1. Se esse erro ocorrer após configurar HTTPS no TOTVS Fluig Plataforma, pode ser devido a falta de um certificado intermediário na configuração: Para solucionar isso, é necessário informar no arquivo host.xml o certificado intermediário.
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Acesse o seu TOTVS Fluig Plataforma e clique no símbolo de cadeado na URL.
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Em seguida clique em Informações do certificado e na aba Caminho de Certificação. Nesta imagem o certificado intermediário é USERTrust RSA Domain Validation Secure Server CA.
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É necessário encontrar o arquivo .p12 deste certificado e informá-lo no arquivo host.xml da plataforma Fluig. Configure na tag <keystore> dentro do <security-realm name="ApplicationRealm"> o parâmetro path com o caminho para este certificado.
Em caso de utilização de servidor de balanceamento, insira o parâmetro SSLCertificateChainFile no servidor apontando para o certificado baixado (neste caso pode ser um arquivo .crt).
Atenção! As plataformas de dispositivos móveis possuem limitações com relação aos certificados digitais. Apenas os certificados homologados por elas são reconhecidos como confiável por padrão. Para evitar a aquisição de certificados não homologados, consulte a documentação técnica de cada plataforma sobre a lista de certificados reconhecidos como confiáveis.
2. O horário do servidor e do aparelho devem ser iguais, se não ocorre erro de timestamp e não é possível realizar a conexão. Caso não estejam iguais, o horário do servidor ou do smartphone deve ser corrigido para que fiquem equiparados.
3. As configurações de rede podem fazer com que a requisição POST do Mobile esteja redirecionando via HTTP 302 para outro endereço. Isto acarreta a perda do Body da requisição, que chega sem parâmetros ao servidor, causando o erro e registrando no log a mensagem: Erro ao tentar criptografar Token OAuth: Erro ao criptografar informações null. Nesse caso, é necessário verificar se está ocorrendo redirecionamento da requisição POST quando enviada via Mobile. Caso esteja, ajustar as configurações de rede.
Saiba Mais
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