Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao realizar o Fechamento Mensal, é gerada a mensagem "Já existe um período no cadastro de período para a filial XX" no log de ocorrências, e o período não é fechado.
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as Versões.
Causa
A mensagem ocorre em casos que foi feita a inclusão indevidamente de um registro com este período na rotina Período de Apontamento, através do botão Incluir:
O botão de Incluir não deve ser utilizado, visto que os fatores determinantes para habilitar os períodos no Ponto Eletrônico são:
- conteúdo dos parâmetros MV_PAPONTA e MV_PONMES
- data base do sistema
Diferente da Folha de Pagamento, no modulo do Ponto Eletrônico o usuário nunca deve criar/incluir registros nessa rotina, visto que as linhas presentes nela sempre deverão mostrar períodos que já foram fechados pela rotina de Fechamento Mensal. Para mais informações referente ao fechamento clique aqui
É possível identificar registros criados pelo usuário de duas formas:
- se a bolinha estiver com cor verde;
- através da tabela SPO, se o campo PO_RESPONS estiver como U de usuário.
Solução
Para que não seja gerada esta mensagem no log e o período possa ser fechado, será necessário deletar a linha com o período em questão na rotina de Período de Apontamento, em Atualizações> Cadastro do Ponto> Períodos de Apontamentos através de Outras ações/excluir. Após executar novamente a rotina de Fechamento Mensal.
Saiba Mais:
RH - Linha Protheus - PON - Rotina Período de Apontamento - PONA290
RH - Linha Protheus - PON - Após o fechamento mensal, o sistema não alterou o período de apontamento
Manual do Ponto Eletrônico
Pacote de Expedição Contínua Acumulado de RH
0 Comentários