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Ocorrência
No módulo Fiscal, ao tentar encerrar uma transação para gerar a nota fiscal é apresentada a mensagem:
Operação Estadual, CFOP do produto (item:X) deveria iniciar com 1 (entrada) / 5 (saída) e está iniciando com 2 (entrada) / 6 (saída) (CFOP:X)!
Ambiente
TOTVS Varejo - Moda - Fiscal
Causa
Esse incidente ocorre quando a empresa logada e a pessoa da transação são do mesmos estado, porém a regra fiscal que está sendo utilizada possui um CFOP interestadual (quando remetente e destinatário são de estados diferentes).
Por padrão, quando a empresa for gerar uma nota de entrada de um fornecedor do mesmo estado que ela, é utilizado o CFOP com o inicio 1 (Entrada o mesmo estado). Já quando a pessoa for de um estado diferente, é utilizado o CFOP com o início 2 (entrada de estados diferentes). E para entrada do exterior é utilizado o CFOP com o inicio 3 (entrada exterior).
Quando a empresa for gerar uma nota de saída para uma pessoa/cliente/empresa do mesmo estado que ela, é utilizado o CFOP com o inicio 5 (saída do mesmo estado). Se o destinatário da nota de saída for de um estado diferente é utilizado o CFOP com o inicio 6 (saída de estados diferentes). E na saída para o exterior é utilizado o CFOP com o inicio 7 (saída exterior).
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Alinhe com sua contabilidade o código do CFOP correto para a movimentação que está realizando. Em seguida identifique qual regra fiscal foi aplicada na transação que está tentando finalizar, conforme passo a passo: Varejo - Moda - FIS - Verificar Regra Fiscal vinculada a Transação;
2. Ao identificar a regra fiscal utilizada acesse o componente FISFM087 - Manutenção de Nova Regra Fiscal, informe o código da regra fiscal e altere o código do CFOP conforme orientado pela contabilidade da empresa. Segue passo a passo para manutenção/cadastro da regra fiscal: Varejo - Moda - FIS - Como cadastrar regra fiscal no componente FISFM087;
3. Após realizar o ajuste dê continuidade na transação através do componente TRAFP005 - Continuação de Transação de Venda, conforme passo a passo: VA - VAR - Continuar Transação de Venda. E caso a mensagem persistir, cancele a transação através do componente TRAFP006 - Cancelamento de Transação, seguindo o passo a passo Varejo - Moda - FAT - Como cancelar uma Transação, e em seguida gere uma nova transação.
Observação
Caso o sistema tenha aplicado a regra fiscal principal ou uma regra relacionada incorretamente ao invés de pegar a correta, analise se a regra que era para ter aplicado está atendendo a todas as condições com base na movimentação que está gerando. Pois se o sistema acatou a regra fiscal principal é porque as regras relacionadas não atenderam aos quesitos dessa nota. Para maiores dúvidas de como analisar as condições das regras relacionadas através do componente FISFP165 - Simulador de Regra Fiscal, Clique aqui!
Adicional
Para assistir nosso How To sobre como cadastrar uma regra fiscal no componente FISFM087, Clique aqui!
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