Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Como corrigir a mensagem Is not allowed more than one source with same name. Rename your source

time.png Tempo aproximado para leitura: 00:15:00 min

Ocorrência
Ao tentar compilar ou executar o ponto de entrada LJ7016 ocorre a mensagem "Is not allowed more than one source with same name. Rename your source"

Ambiente
TOTVS Varejo - Varejo Lojas linha Protheus - Controle de Lojas - a partir da release 12.1.33

Causa

A partir da versão 20.3.1.x do AppServer foi implementada uma validação que verifica a existência de código fonte com mesmo nome em ambos os RPOs (RPO Padrão e RPO Custom). Essa verificação ocorre tanto na compilação como também na execução da rotina.

Devido já existir no RPO padrão um fonte com o nome (LJ7016.PRW do módulo Saúde do Protheus), o AppServer aborta a execução da rotina e emite a mensagem sugerindo a mudança de nome do fonte RDMake que está no RPO Custom.

Para mais detalhes, segue link da documentação que cita a respeito desta validação implementada no AppServer:https://tdn.totvs.com/pages/viewpage.action?pageId=718973999


Solução

Para solucionar este problema, deve ser realizado o seguinte passo a passo:

  1. Remover o fonte RDMake LJ7016.PRW que está compilado no RPO Custom;
  2. Alterar o nome do código fonte RDMake LJ7016.PRW. (Exemplo: LJ7016_CUST.PRW);
  3. Compilar o RDMake que foi renomeado.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    Diego Ernane Silva Figueiredo

    fazendo isso o ponto de entrada do sigaloja para de funcionar.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _