Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - FGL - Integração automática de cotação apresenta uma sequencia de erros

time.png Tempo aproximado para leitura: 00:00:55 min

Ocorrência
Na execução do programa UTB764ZA - Importação Cotação BC (prgint/utb/utb764za.r) o Sistema apresenta a sequência de erros: 
Invalid handle.  Not initialized or points to a deleted object. (3135)
Handle inválido. Não Inicializado ou aponta para um objeto excluído. (3135)
** val_cotac_indic_econ é mandatório, mas tem o valor ?. (275)
** Não foi possível modificar b_cotac_parid. (142)
 
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contabilidade Fiscal (FGL) - Versão 12

Causa 
A funcionalidade depende de procedimentos prévios de parametrização para a correta execução da rotina.

Solução
Realizar os procedimentos e verificações de cada tópico listado abaixo. Se persistir a ocorrência dos erros, encaminhar os detalhes da verificação efetuada, extrato de versão e clientlog da última simulação dos erros, e o relatório gerado pela rotina.
 
Para realização dos procedimentos, executar na forma online
Quando os erros deixarem de ocorrer, testar a rotina no modo batch.

  1. Confirmar se as regras para realizar a busca das cotações do programa UTB764ZA tiveram definição recente, caso definidas em versões anteriores, eliminar, e efetuar nova inclusão;
  2. Enquanto ocorrerem erros na execução, definir somente uma regra para as novas execuções. Não parametrizar a opção Replicação;
  3. A rotina não integra de forma retroativa. No relatório gerado, é apresentada a data utilizada para realizar a integração. No caso de sábados, domingos e feriados, o Banco Central não libera os arquivos de cotação. A informação Data Cotação determina a utilização da data da integração. É possível informar as opções: Hoje ou Dia Anterior. Ao parametrizar a opção Hoje, quando o Sistema não localiza o arquivo das cotações, ocorre a busca do arquivo do dia anterior ou do último dia útil, portanto, é necessário manter o cadastro do calendário sempre atualizado;
  4. O arquivo das cotações utilizado pela rotina é disponibilizado diariamente no site do Banco Central do Brasil. Se informar o endereço com uma data futura, ou dias que compõem o fim de semana ou feriado, serão apresentados erros. O arquivo normalmente fica disponível no início da tarde, e podem ocorrer erros também na busca do dia corrente, quando o mesmo ainda não está disponível.
    Se acessar pelo navegador o link https://www4.bcb.gov.br/download/fechamento/20220830.csv, o arquivo das cotações de 30/08/2022 é disponibilizado. Portanto na ocorrência da sequencia de erros, orientamos acessar o arquivo diretamente pelo navegador, utilizando a data listada no relatório: https://www4.bcb.gov.br/download/fechamento/aaaammdd.csv;
  5. Na documentação do programa Importação Cotação BC, além da inclusão das bibliotecas, o documento alerta que a rotina necessita ter o firewall liberado para download do arquivo de cotações: https://www4.bcb.gov.br/download/fechamento/20220830.csv  ;
  6. Ao acessar o link www4.bcb.gov.br pelo navegador, verificar se no acesso erros são visualizados.
  7. Empresas que utilizam rede certificada, os certificados que são instalados de forma automática pela rotina não surtem efeito. A orientação neste caso, é que os certificados sejam baixados através do navegador e devem ser aplicados manualmente através do Proenv do Progress. Os certificados do Banco Central do Brasil são públicos, podem ser salvos diretamente à partir do seu endereço.  No navegador web, acessar https://www.bcb.gov.br. Clicar no botão do cadeado, normalmente localizado perto da barra do endereço. Localize a opção para mostrar os certificados e usar a opção Exportar.

7-1. Exemplo de acesso para o certificado padrão usado pela rotina, que deve constar no endereço:  ...\fnd\univdata\certs

certificado-bcb.jpg

7.2. Imagem que exemplifica uma rede certificada, empresa fictícia EmpABC, onde o certificado difere do padrão DigiCert Global Root G2 aplicado de forma automática pela rotina:

rede-certificada.jpg

Importante
Análise dos impedimentos e ajustes necessários são realizados pela Equipe de Consultoria. Anexos requeridos para análise de problema pela equipe de Suporte:

  • Extrato de Versão;
  • Relatório log da integração;
  • Clientlog da simulação do problema que impede a integração;
  • Detalhes da cadeia de certificado do site do Banco Central, conforme exemplo pela imagem do item 7.1.  

Saiba mais
Mais detalhes do erro que também se relacionam aos controles do certificado, acessar  http://www4.bcb.gov.br/download/fechamento/20231113.csv 0 não encontrado
Artigo relacionado: Framework - Linha Datasul - TEC - Aplicação de certificados no Progress:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _