Tempo aproximado para leitura: 00:01:00 min
Ocorrência
Problema de arquivo não encontrado, na atualização das cotações à partir do BACEN - Banco Central do Brasil.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contabilidade Fiscal (FGL) - Versão 12
Causa
O Banco Central exige certificado para acessar o arquivo utilizado pelo programa UTB764 - Importação Cotação Automática (prgint/utb/utb764aa.r).
Solução
O arquivo das cotações utilizado pela rotina é disponibilizado diariamente no site do Banco Central do Brasil. Na versão atual do programa UTB764AA - Importação Cotação BC (prgint/utb/utb764za.r) a atualização do certificado ocorre de forma automática.
Acessar pelo navegador o arquivo indicado pela mensagem e confirmar se o arquivo das cotações é baixado.
Avaliar se o certificado, disponibilizado em anexo neste artigo, consta no endereço: ...univdata\certs\DigiCertGlobalRootG2.
Ambientes com rede certificada, causa erro na instalação automática dos certificados programa UTB764. Para resolver o problema, acionar a equipe de Consultoria Datasul ou aplicar o certificado manualmente no diretório de instalação do PROGRESS, através do PROENV do PROGRESS. O ajuste deve ocorrer na máquina ou servidor onde roda o Progress.
Importante
Para análise de problemas na execução da rotina, providenciar o clientlog da simulação do problema.
Saiba mais
Seguir os passos necessários para aplicar o certificado no Progress no artigo Framework - Linha Datasul - TEC - Aplicação de certificados no Progress - Dúvidas sobre os procedimentos acessar os canais de atendimento do Suporte Banco de Dados (2-2-4-8-3).
Se a mensagem de arquivo não encontrado persistir, ou quando ocorrer sequencia de erros no processo, avaliar orientações relatadas no artigo
Cross Segmentos - Linha Datasul - FGL - Integração automática de cotação apresenta uma sequencia de erros
0 Comentários