Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro ao gerar S-2200: O campo 'paisNascto' do registro 'nascimento' é obrigatório e não está preenchido

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao gerar o XML do evento S-2200 é apresentado o erro O campo 'paisNascto' do registro 'nascimento' é obrigatório e não está preenchido.

Ambiente
TOTVS RH - TOTVS RH -  (Linha RM) - Folha de Pagamento - eSocial - Todas as Versões

Causa
O erro é apresentado quando o sistema não está com as informações de Países configurados.

Solução
Para realizar a configuração de países, siga os passos abaixo:

1. Acesse eSocial | Endereços | Classificação de Países  inclua um novo registro que será identificada para o eSocial;

2. Acesse Configurações | Parametrizador | eSocial | De/Para de Endereço e informe o item criado no passo 1 no campo Conceito de Classificação para Códigos de Países;

3. Após, em eSocial | Endereços | Países. Edite o país desejado e em Anexos | Codificação de País associe a Classificação criada no passo 1 e, no campo Código País informe o código presente na coluna Código do País da Tabela 06 - Países do leiaute do eSocial;

 

 

4. Identifique no cadastro do funcionário a Nação que consta informada;

4.1. Após, acesse eSocial | Endereços | Classificação de Nações e para o registro de nação desejada informe o nome do país correspondente;

5. Regere o XML.

 

Saiba mais
Para mais detalhes, acesse:
     - Como realizar a associação da Tabela de Países do layout do eSocial no cadastro do sistema?
     - Como realizar a liberação de acesso aos cadastros de endereço na aba eSocial?
     - O campo 'paisNac' do registro 'nascimento' é obrigatório e não está preenchido 

Esse artigo foi útil?
Usuários que acharam isso útil: 2 de 3

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _