Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - MRE - Mensagem 17.006 - Registro está sendo utilizado por outro usuário

time.png Tempo aproximado para leitura: 00:01:12 min

Ocorrência
Ao incluir um documento no programa RE1001 - Manutenção de Documentos, ocorre a mensagem 17.006 - Registro está sendo utilizado por outro usuário!

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Recebimento (MRE) - Versão 12

Causa 
Esta mensagem pode ser apresentada quando o documento está relacionado ao usuário indevidamente, ou seja, se houve queda de energia ou outra intermitência no Sistema durante da inclusão do documento no programa RE1001, que deixou o registro preso ao usuário. 

Solução
Para corrigir a situação, é necessário verificar se o documento já existe no RE1001 ou, se já está atualizado no Sistema, utilizando a tela RE0701A - Detalhes Documentos. Em seguida, executar o programa RE0402 - Desatualização Documentos, informando os dados da nota no filtro da aba Seleção e na aba Parâmetros não marcar nenhuma opção e clicar em Executar para desatualizar este documento.

Após, eliminar esse documento no programa RE1001 e realizar a inclusão novamente.

Se ainda assim a situação persistir será necessário identificar o motivo do registro preso, seguindo as orientações da documentação: Framework - Linha Datasul - TEC - Como identificar locks no banco Progress OpenEdge

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

1 Comentários

  • Avatar
    Edson Cordeiro dos Santos

    Essa solução não representa a realidade, se o documento esta com erro no RE1001 no botão itens,  não é possível desatualizar um documento que não foi atualizado. Se foi colocada a validação no programa para impedir que outro usuário altere os itens da nota no mesmo RE1001 a Totvs precisa localizar e retornar qual usuário está gerando o travamento para que a ações indicadas como solução possam ser executadas.

    2
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _