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Ocorrência
Ao realizar a atualização manual das licenças no TOTVS License Monitor, ocorre o erro abaixo:
Falha ao recuperar a autorização do licenciamento TOTVS. Tente mais tarde...
Ambiente
Framework - Linha RM - Todas as versões do sistema RM
Causa
Esse incidente ocorre devido a falta de comunicação com o servidor de licenças TOTVS.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. O TOTVS | License Server necessita de acesso à internet para sua instalação e operação.
O acesso é realizado através do protocolo HTTPS e toda a comunicação é feita pela porta 443. Caso a sua empresa possua firewall e/ou restrições de acesso à internet, é necessário que o administrador da rede libere o acesso para o endereço https://licenseservercloud.totvs.com.br/ e https://lscloud.totvs.app/api/ (Este é o endereço base dos serviços do License Server). O tipo de conexão realizada é outbound (O License Server realiza uma chamada cliente a um servidor na Internet).
Aviso:
Utilize sempre o endereço DNS https://lscloud.totvs.app/api. A utilização do seu respectivo endereço IP pode causar interrupção na atualização diária das licenças caso a Totvs altere o endereço IP. Isso não fará com que o LS Virtual pare de funcionar de imediato, mas pela perda de comunicação diária, passará a exibir a mensagem de expiração da licença e obrigará uma intervenção manual de troca do IP ou alteração para o DNS (lscloud.totvs.app/api) na regra do seu servidor.
2. Realize o teste de comunicação via telnet e tracert.
3. Realize o teste de comunicação através do aplicativo HTTPAnalyser.
4. Realize novamente o teste de atualização manual.
5. Caso a mensagem persista, siga os passos abaixo:
5.1. Pare o serviço do License Server Virtual nos serviços do Windows.
5.2. Renomeie o arquivo licenseserver.ini dentro da pasta Appserver do LSV.
5.3. Renomeie os diretórios db_sys, db_tmp e semáforo dentro da pasta data do LSV.
5.4. Inicie o serviço do LSV nos serviços do Windows e acesse o monitor.
5.5. No Portal do Cliente em Gestão de Licenças, clique na aba Instalações, altere o horário de atualização no Portal de Noturno para Diurno e clique em Salvar:
5.6. Na pagina de Instalações inclua um novo TOTVS ID ou copie um que não foi utilizado: Como incluir novo TOTVS ID
5.7. Inclua este novo TOTVS ID no License Server Monitor e bloqueie o TOTVS ID anterior;
5.8. Ainda no Gestão de Licenças clique na aba Licenças;
5.9. Clique em cima de todas as licenças e verifique se as mesmas estão distribuídas para o TOTVS ID correto, caso não esteja realizar a distribuição seguindo as orientações do artigo Como remanejar licenças no LSV;
5.10. No monitor do License server Virtual clique no ícone com formato de antena para realizar a atualização manual;
5.11. Clique no ícone com formato de duas setas e verifique se as licenças foram apresentadas e a data de autorização de uso atualizada:
6. Caso a inconsistência persista, recomendamos que realize a reinstalação do License Server Virtual.
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