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Ocorrência
Quando você acessa o Meu RH, pode enfrentar problemas de lentidão. Como identificar a causa da baixa performance e quais são as melhores práticas para melhorar a performance do Meu RH?
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir do release 12.1.27
Causa
A lentidão no Meu RH pode ser causada por diversos fatores, incluindo configurações do ambiente, um grande número de acessos simultâneos, quantidade de licenças utilizadas, e o desempenho da infraestrutura atual.
Solução
Criamos uma documentação conforme link abaixo, que detalha todas as configurações recomendadas para melhorar a performance do Meu RH. Recomendamos que você leia atentamente toda a documentação preparada. Se, após seguir essas orientações, o problema persistir, continue consultando o restante deste KCS para mais informações e soluções adicionais.
Clique aqui para acessar o documento das melhores práticas específicas para o Meu RH !!!
Se, mesmo seguindo todas orientações acima, continuar enfrentando problemas de desempenho na usabilidade do Meu RH, verifique os itens listados abaixo:
1. Quantidade de Licenças: Consumo ao Atingir o Limite
Quando o número de licenças do Meu RH atinge seu limite, os usuários não recebem uma mensagem de erro. Em vez disso, o sistema se torna mais lento, pois as requisições ficam em espera até que novas licenças sejam liberadas no pool. Essa espera causa uma lentidão geral no uso do Meu RH.
Para verificar se essa é a causa, acesse o Monitor de Licenças e acompanhe o uso durante os horários de pico da empresa. As licenças utilizadas pelo Meu RH são: 4177, 4001, 4000, 4099 e 4016.
Clique aqui para acessar o documento de como monitorar as licenças em tempo real
Clique aqui para acessar o documento sobre maiores explicações sobre o funcionamento do consumo das licenças do Meu RH.
Caso identifique que estão chegando muito próximo ao limite, entre em contato com o seu ESN (Executivo de Soluções de Negócio) para avaliar a necessidade de adquirir mais licenças.
2. Desempenho da Infraestrutura: Processamentos, Memória ou Banco de Dados Atingindo Níveis Críticos
Assim como no item 1, durante os horários de pico, é essencial monitorar o servidor onde o Meu RH está instalado, também o servidor de aplicação que hospeda o Host consumido pelo Meu RH e, finalmente, o servidor do banco de dados. Todos esses servidores devem ser acessados e monitorados rigorosamente. Fique atento aos níveis de processamento e memória; se esses níveis se aproximarem de 90%, a performance do Meu RH pode ser significativamente afetada.
Caso identifique algum nível crítico, considere a possibilidade de dimensionar o hardware. Para orientações sobre as recomendações de dimensionamento, consulte nosso documento de Portabilidade clicando aqui.
Recomendações Relacionadas à Infraestrutura:
2.1 Importante utilizar servidores de aplicação (serviços de hosts) dedicados para o Meu RH, assim não terá concorrências com acessos e processamento do ERP RM.
2.2 Avalie a possibilidade de aumentar a quantidade de Hosts utilizados pelo Meu RH.
3. Inconsistência na Estrutura de Seção do Módulo Folha de Pagamento, Causando Lentidão no Meu RH
Quando a coluna CODIGOPAI e a coluna CODIGO na tabela PSECAO possuem o mesmo identificador, isso pode causar uma queda repentina do Host ou instabilidade e lentidão no Meu RH. Para ajudar a identificar e solucionar esse problema, criamos um KCS específico que demonstra como resolver esse incidente.
Clique aqui para acessar o documento para identificar e solucionar a lentidão causada na estrutura de seção que afeta o Meu RH

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