Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - PTO- Dicas para melhorar a performance do Automação de Ponto

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Caso no Totvs Automação de Ponto, ao efetuar rotina de recálculo e geração do relatório do espelho do cartão, e entrentar problemas de lentidão, como identificar a causa da baixa performance e quais são as melhores práticas para melhorar a performance?

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir do release 12.1.2510

Causa 
A lentidão no RM TOTVS Automação de Ponto pode ser causada por diversos fatores, incluindo configurações do ambiente, um grande número de acessos simultâneos,  locks em tabelas do banco, desempenho da infraestrutura atual, fórmulas de evento no movimento e fórmulas de evento no banco de horas, entre outros fatores.

Solução
Criamos a documentação abaixo, que detalha as principais configurações recomendadas para melhorar a performance de recálculo do ponto. Recomendamos que você leia atentamente toda a documentação preparada. Se, após seguir essas orientações, o problema persistir, continue consultando o restante deste KCS para mais informações e soluções adicionais.

RH - RM - PTO - Fracionamento de JOBS ao recalcular

Segurança de Jobs Fracionáveis

No link de Segurança de Jobs Fracionáveis é possível fracionar o processo de geração do relatório do espelho do cartão de ponto. Basta seguir a documentação e adicionar a classe de job PtoProcRelatEspelhoCartao e seguir as orientações de acordo com seu cenário.

Se, mesmo seguindo todas orientações acima, continuar enfrentando problemas de desempenho na usabilidade dos processos, verifique os itens listados abaixo:

  1. Se a lentidão estiver no processo de recálculo, verifique se desmarcar as opções de 'Calcula eventos por fórmula no movimento' e 'Calcula eventos por fórmula no banco de horas' o processo será executado de forma mais rápida. Se o processo executar de forma rápida, fica confirmado que as fórmulas customizadas precisam ser otimizadas.

    recalculo.png
     
    Se precisar de acompanhamento para análise da performance e otimização das fórmulas customizadas, temos nosso time de consultoria técnica que poderá apoiá-lo na análise. Se optar por este caminho basta retornar no ticket manifestando este interesse que direcionamos o atendimento para que o time lhe informe os procedimentos e valores.
     
  2. Caso a lentidão ocorra em processos específicos, ou seja, somente no módulo de ponto, avalie se no gerenciamento de jobs, há jobs de recálculo, lançamento de batidas pelo horário planejado, ou mesmo importação de batidas em concorrência. Jobs de diferentes processos do módulo do ponto executando simultaneamente podem causar locks no banco, ou mesmo lentidão nos processos.

    Agendamentos de jobs executando simultaneamente, também podem causar lentidão.

    Para identificar jobs agendados, segue documentação:
    Framework - Linha RM - Frame - Identificar job agendado

    Se identificar vários jobs agendados, sem necessidade, podendo causar lentidão, segue documentação para desabilitá-los:
    Framework - Linha RM - Frame - Como desabilitar job agendado
     
  3. Se a lentidão estiver de forma generalizada, ou seja, em qualquer processo, qualquer módulo, sugerimos verificar a documentação abaixo:
    Framework - Framework RM - BD - Orientações Gerais para Otimização de Performance

Saiba mais
Para avaliar locks no banco, segue documentação para base SQL:
Framework - Framework RM - BD - Como verificar Deadlock no SQL Server

Como apoio, para auxiliar no monitoramento do ambiente, segue documentação sobre o Sentinela:
Framework - Framework RM - BD - Sentinela RM Ferramenta de Monitoramento de Ambientes

Importante
Se houver necessidade de investigação mais aprofundada em seu ambiente, temos nosso serviço TIS. O Infraestrutura de Sistemas é o serviço especializado de análise, sustentação e evolução da infraestrutura que suporta os sistemas de gestão da TOTVS.
Para maiores detalhes, segue link TIS

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _