Tempo aproximado para leitura: 00:01:00 min
Ocorrência
Mesmo não utilizando o Smartclient Web, no log da Leitura/Apontamento é exibida a mensagem: "Durante a utilização do WebApp, arquivos que estão fora da pasta Protheus_Data não serão lidos. Por favor coloque o arquivo do relógio dentro da pasta Protheus_Data e altere o cadastro do relógio ou execute a rotina pelo Smartclient."
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico – A partir da versão 12.1.23
Causa
Esta mensagem é exibida quando existe uma divergência entre o nome do arquivo TXT salvo na pasta X o nome informado no cadastro do relógio, ou quando o usuário deixa de usar algum relógio de ponto, e para fins de histórico, mantém o cadastro no Protheus, porém, deixa o campo Nome Arquivo (P0_ARQUIVO) em branco.
Solução
Para que a mensagem não seja exibida e não cause problemas no processo da Leitura/Apontamento, o usuário deve:
1. Validar se o nome do arquivo TXT está exatamente igual ao informado no campo Nome Arquivo do cadastro do relógio. No exemplo da imagem abaixo o arquivo TESTE1.txt está no C: dentro da pasta Ponto.
2. Caso exista um relógio de ponto que não é mais utilizado, o cadastro do Protheus deve ser mantido para fins de histórico, porém, orientamos que deixe o campo Nome Arquivo (P0_RELOGIO) preenchido.
Veja como realizar o Cadastro do Relógio de Ponto
3. Verifique se o ambiente possui o WebAgent instalado;
4. Verifique se a Porta do Webagent está habilitada:
Saiba Mais
Pacote de Expedição Contínua - Acumulado de RH
Manual do Ponto Eletrônico
WebAgent
0 Comentários