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Varejo Supermercados - Movimentações - Importações - Falha na integração de vendas do PDV com Error Code 1033: Incorrect information in file

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
No PDV do varejo Supermercados, as vendas deixam de integrar para o Monitor de PDVs.

Ao analisar os logs da aplicação(app_<data>.log), são apresentadas mensagens semelhantes a:

Error Code: 1033 Incorrect information in file

Exemplo identificado: Incorrect information in file: './consinco/tb_doctoprepago.frm'

Ambiente
TOTVS Varejo - Supermercados PDV - Linha Consinco - Aplicável para todas as versões.

Causa 
Esse incidente ocorre devido à corrupção da estrutura de alguma tabela local do banco MySQL do PDV.

No cenário de exemplo deste KCS, a corrupção ocorreu na tabela:

tb_doctoprepago

Porém, o comportamento pode ocorrer com qualquer tabela da base local.

Quando o arquivo estrutural .frm ou .ibd da tabela está corrompido, o banco local não consegue realizar corretamente consultas SQL utilizadas no processo de integração das vendas, ocasionando falha no envio dos movimentos para o Servidor/Monitor

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Passo 1. Validar os logs do PDV e localizar mensagens semelhantes a: 

Error Code: 1033 Incorrect information in file

Passo 2. Identificar no log qual tabela está apresentando corrupção.

Exemplo: Incorrect information in file: './consinco/tb_doctoprepago.frm'

Passo 3. Acessar o diretório do banco local do PDV:

  • PDV Windows: C:\ProgramData\MySQL\MySQL Server 5.5\data\consinco
  • PDV Linux: /var/lib/mysql/consinco/

Passo 4. Localizar os arquivos da tabela afetada, exemplo: 

tb_doctoprepago.frm
tb_doctoprepago.ibd

Passo 5. Obter o arquivo .frm ou .ibd correspondente de um PDV saudável com mesma versão e mesma estrutura de banco.

Passo 6. Substituir o arquivo .frm ou .ibd corrompido no PDV afetado.

Passo 7. Reiniciar os serviços do PDV ou reinicializar a máquina.

Passo 8. Validar se as vendas voltaram a integrar normalmente para o Servidor/Monitor

Importante
O procedimento acima possui caráter paliativo/emergencial. 

Após integrada as vendas, é importante realizar a reinstalação do PDV para evitar novos casos ou perda de informações. 

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