Tempo aproximado para leitura: 00:01:00 min
Ocorrência
Ao tentar realizar o login no Meu RH, é apresentado a mensagem de erro "Falha na verificação da base de dados! A versão da Base de Dados é mais recente que a versão do aplicativo!".
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH – Todas as versões
Causa
Esse incidente ocorre quando há divergência de versão entre a base de dados e as bibliotecas do RM ou do RM Portal.
Por exemplo:
A Base de Dados foi migrada para a versão 12.1.2602
Porém o RM / RM Portal está na versão 12.1.2510
Nesse cenário, as versões ficam diferentes entre si, ocasiona o erro em questão.
Solução
Para o funcionamento correto, é necessário a Biblioteca RM, RM Portal e Base de dados estejam sempre na mesma versão/patch. Exemplo:
- Versão Biblioteca RM: 12.1.2602
- Versão RM Portal: 12.1.2602
- Versão Base de dados: 12.1.2602
Caso exista divergência entre essas camadas, é necessário realizar a atualização do RM / Portal ou da Base de Dados, garantindo que todas estejam na mesma versão.
Para saber como identificar a versão da Biblioteca RM e RM Portal, acesse: RH - RM - Meu RH - Como verificar Versão e Patch da Biblioteca RM e Meu RH
Para saber como identificar a versão da Base de dados, acesse: Framework - Linha RM - Frame - Identificar a versão da base de dados
Saiba Mais:
Framework - Linha RM - Frame - Como atualizar o release da biblioteca RM
0 Comentários