Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - OMS - Quando o help OMS32001 será apresentado na rotina OMSA320

time.png Tempo aproximado para leitura: 00:03:12 min

Ocorrência
Ao realizar o retorno de cargas na rotina OMSA320, o sistema pode apresentar o help OMS32001, impedindo a gravação do registro quando a data de entrega informada é anterior à data de emissão da Nota Fiscal.

Mensagem apresentada: 
OMS32001
“A data de entrega informada é menor do que a data de emissão da nota fiscal.
Informe uma data de entrega maior ou igual à data de emissão da nota fiscal.”

Ambiente
TOTVS Logística - TOTVS OMS (Linha Protheus) - Gestão de Distribuição (SIGAOMS) - Todas as versões

Causa
Foi identificada a possibilidade de inconsistências no processo de retorno de cargas quando o sistema permitia informar uma data de entrega inferior à data de emissão da Nota Fiscal. Para evitar esse cenário, foi implementada uma nova validação no OMS que compara os seguintes campos:

F2_DTENTR – Data de Entrega
F2_EMISSAO – Data de Emissão da Nota Fiscal

Quando a data de entrega for menor que a data de emissão, o sistema bloqueia a operação e exibe o help OMS32001.

Solução
A correção foi aplicada para garantir a integridade das informações, impedindo o usuário de informar uma data de entrega anterior à data de emissão da Nota Fiscal. A partir dessa validação, o sistema exige que:
A data informada no campo F2_DTENTR – Data de Entrega seja maior ou igual à data do campo F2_EMISSAO – Data de Emissão da Nota Fiscal.
Caso a regra não seja atendida, o retorno da carga não será concluído.

Para informar a data entrega, acesse a rotina OMSA320, selecione a carga desejada.
No campo Data de Entrega - F2_DTENTR, informe uma data igual ou posterior à F2_EMISSAO – Data de Emissão da Nota Fiscal. Salve o retorno da carga.
Caso a data informada seja inferior à data de emissão, o sistema exibirá o help OMS32001 e impedirá a gravação.

Importante
Para realizar o retorno com uma data de entrega anterior à data de emissão da Nota Fiscal, disponibilizamos o parâmetro MV_OMDTANT, que possibilita contornar essa validação. O detalhamento desse parâmetro pode ser consultado na seção Saiba Mais, logo abaixo. Entretanto, cabe a cada cliente avaliar a necessidade de utilização desse recurso, considerando que a data de entrega informada no retorno da carga atualiza o campo F2_DTENTR – Data de Entrega, utilizado no preenchimento da tag da NF-e.

Saiba mais
Mais informações poderão ser acessadas os links
Inclusão de Validação de Data Entrega no Retorno de Carga
Boletim Técnico - Parâmetro MV_OMDTANT
Logística - Linha Protheus - OMS - Como efetuar o retorno parcial de carga na rotina OMSA320 -  Retorno de Cargas
Logística - Linha Protheus - OMS - Quais funcionalidades compreende a rotina de Retorno de Cargas
Logística - Linha Protheus - OMS - Pontos de Entrada disponíveis na rotina Retorno de Cargas - OMSA320

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _