Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH – RM – Meu RH – Aviso de Férias gerado com data incorreta quando existe mais de um período de férias marcado

time.png Tempo aproximado para leitura: 00:03:25 min

Ocorrência
Quando um colaborador possui mais de um período de férias cadastrados no Meu RH, ao gerar e baixar os avisos, todos os documentos são emitidos com a mesma data do primeiro período de férias, mesmo que os demais períodos estejam registrados corretamente no sistema.



Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir do release 12.1.2406

Causa 
O relatório padrão "Aviso de Férias" do RM Reports, foi desenvolvido a partir da utilização da tabela PFUNC como fonte de dados, dessa forma consegue atender apenas a impressão do aviso de férias do período de gozo mais próximo, tendo em vista que o mesmo fica gravado na tabela. Os demais períodos de gozo marcados, só passam a alimentar a tabela conforme o primeiro altera seu status para finalizada.

Solução
O RM está em constante evolução e vem adotando o Smart View como padrão para o sistema de relatórios. Nesse cenário, nosso time de desenvolvimento está criando novos relatórios alinhados a essa tecnologia, e já está disponível o relatório padrão "FOPTRP0001 – Aviso de Férias", que permite a geração correta do aviso mesmo quando há mais de um período de gozo marcado.

Para utilizar esse novo relatório do Smart View, realize os seguintes passos:

1. Parametrize o Smart View no RM conforme os passos desta documentação: Instalação e Configuração do Smart View

2. Realize o download do relatório FOPTRP0001 – Aviso de Férias através do TOTVS Compartilhamento


3. Acesse Folha de pagamento > Configurações > Parametrizador > Edite o quiosque do funcionário > Férias. Marque a flag Relatorios do Smart View" e vincule o relatório "FOPTRP0001" em Aviso de Férias.

 

Após realizar essa parametrização, será possível gerar corretamente o aviso de férias quando houver mais de um período de gozo marcado, exibindo as datas correspondentes a cada um deles.

Meu RH:

Download dos avisos:

 

Saiba mais:

RH - RM - Meu RH - Como Gerar o Demonstrativo de Pagamento com relatório via SmartView

Documentos de Referência Smart View

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _