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RH - RM - FOP - eSocial - Erro System.NullReferenceException: Object reference not set to an instance of an object.



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Ocorrência
Ao gerar o S-2299 e apresentado o seguinte erro System.NullReferenceException: Object reference not set to an instance of an object. at RM.Fop.Dominio.Relatorio.RelatorioEFDBaseRemuneracao.<>c__DisplayClass.<GerarInformacoesFolhaPagtoRescisaoTomador>b__0(RateioTomador x) at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at RM.Fop.Dominio.Relatorio.RelatorioEFDBaseRemuneracao.GerarInformacoesFolhaPagtoRescisaoTomador(RegistroRelatorioBase registroPaiDemonstrativo, Funcionario funcionario) at RM.Fop.Dominio.Relatorio.EventoS2299.CalcularCampos() at RM.Fop.Dominio.Relatorio.RelatorioEFDBase.Calcula() at RM.Fop.Esocial.FopEsocialMod.CalcularEvento(RelatorioEFDBase relatorio, FopEventoESocial evento, FopTipoArquivoESocialEnum tipoArquivo, Boolean mapeamentoCampos, String executionId

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as Versões

Causa 
Esse incidente ocorre quando o sistema tenta localizar informações de rateio por tomador de serviços e não encontra a distribuição de encargos, lotação tributária ou dados de vínculo do funcionário.

As causas mais comuns são:

  • Distribuição de SEFIP/Tomador inexistente ou inconsistente no período da rescisão;

  • Lotação Tributária não gerada ou não aceita no eSocial (S-1020 pendente);

  • Histórico de rateio por tomador com registros inválidos.

  • Parâmetro “Utiliza Tomadores de Serviço” marcado indevidamente no Parametrizador da Folha, sem que a empresa utilize tomadores.

Solução
Para corrigir a ocorrência, realize todas as validações abaixo:

1. Verificar a Distribuição do SEFIP | Tomador

O erro pode ocorre porque o sistema não encontra o rateio das verbas para o tomador no período da rescisão.

  • Acesse: Encargos | FGTS | Distribuir Tomador

  • Verifique se a distribuição foi realizada para o mês/ano da rescisão do funcionário;

2. Saneamento da Lotação Tributária (eSocial)

Funcionário vinculado a tomador/obra exigem Lotação Tributária válida.

  • Acesse: eSocial | Lotação Tributária

  • Verifique se a lotação tributária está cadastrada corretamente, com todas as informações obrigatórias preenchidas;

  • Verifique se a lotação está vinculada ao tomador/obra e ao funcionário no período da rescisão;

  • Acesse a fila de eventos e verifique se o evento S-1020, referente à lotação tributária, foi gerado e enviado com sucesso ao eSocial.

3. Validar o parâmetro “Utiliza Tomadores de Serviço” 

Se a empresa não utiliza tomadores de serviço, mas o parâmetro estiver ativo, o sistema tentará buscar rateios inexistentes, gerando o erro.

  • Acesse: Configurações | Parametrizador | Folha Normal | Tomador de Serviços

  • Verifique a opção “Utiliza Tomadores de Serviço”:

    • Marcada → somente se a empresa realmente utiliza tomadores;

    • Desmarcada → se não houver rateio por tomador.

 

Importante:

Esse erro está diretamente ligado ao cálculo da Base de Remuneração por Tomador, utilizada nos eventos rescisórios do eSocial.
Qualquer inconsistência entre rateio, lotação tributária, histórico do funcionário e parametrização da folha pode resultar no NullReferenceException durante a geração do S-2299.

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