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Ocorrência
Ao integrar o evento S-2205, é apresentado o erro código 304: Não existe um Contrato de Trabalho para o CPF: XXXXXXXXXXX ou este encontra-se encerrado na data do evento.. Erro código 2: O campo não pode ser preenchido: Indicador de Preenchimento de Cota. Localização: /eSocial/evtAltCadastral/alteracao/dadosTrabalhador/infoDeficiencia/infoCota.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as Versões
Causa
Esse incidente ocorre porque o evento S-2205 está sendo enviado com o campo Indicador de Preenchimento de Cota (infoCota) preenchido, porém não existe vínculo ativo para o CPF informado na data do evento. O eSocial valida esse campo apenas quando há Contrato de Trabalho vigente, previamente informado por meio dos eventos S-2200 (Cadastramento Inicial) ou S-2300 (Trabalhador Sem Vínculo).
Caso o contrato esteja encerrado ou não exista, o preenchimento do campo infoCota não é permitido.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Verifique se o trabalhador possui Contrato de Trabalho ativo na data informada no evento, conferindo os eventos S-2200 ou S-2300 enviados ao eSocial.
Caso o contrato esteja encerrado, não será possível o envio do evento de Alteração Cadastral (S-2205) com data posterior ao desligamento do trabalhador.
Se o contrato deveria estar ativo, valide se os eventos de admissão (S-2200) ou vínculo (S-2300) foram enviados corretamente e aceitos pelo eSocial.
Após os ajustes, gere novamente o evento S-2205 – Alteração Cadastral e realize um novo envio ao eSocial.
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