Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro de schema: Element '{http://www.esocial.gov.br/schema/evt/evtAfastTemp/v_S_01_03_00}observacao'


time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Ao gerar o arquivo XML S-2230 (Afastamento Temporário), é apresentado o seguinte erro: Erro de schema: Element '{http://www.esocial.gov.br/schema/evt/evtAfastTemp/v_S_01_03_00}observacao': [facet 'minLength'] The value has a length of '0'; this underruns the allowed minimum length of '1'. 
Element '{http://www.esocial.gov.br/schema/evt/evtAfastTemp/v_S_01_03_00}observacao': [facet 'pattern'] The value '' is not accepted by the pattern '[\s\S]{1,255}'.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as versões

Causa 
O incidente ocorre quando o campo Observação no Histórico de Afastamento do colaborador está preenchido com espaço em branco.
O leiaute do evento S-2230 exige que este campo contenha ao menos um caractere, caso seja preenchido.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o RM Folha de pagamento, administração de pessoal selecione o funcionário que será enviado o S2230, Administração de Pessoal → Anexos → Histórico → Histórico de Afastamento

2. No registro de afastamento, limpe o espaço em branco do campo, ou preencha com qualquer informação relevante (mínimo de 1 caractere).


 

3.  Salve as alterações, gere novamente o arquivo XML S-2230.

 

Saiba mais:

Para mais informações sobre a geração de gatilhos do S-2230, acesse:
     - S-2230 Afastamento Temporário

 


 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _