Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - FAS - DCF727ZA - Ocorreu o erro 21027 no processo executado

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao efetuar a importação de bens é apresentada a mensagem Ocorreu o erro 21027 no processo executado.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) – Ativo Fixo (FAS) – Versão 12

Causa
O erro destaca inconsistência nos dados dos bens em implantação pelo processo de importação. Normalmente sua ocorrência está associada a erro na definição dos dados dos arquivos de importação.

Solução
O Sistema efetua validações de acordo com as regras de negócio definidas para o controle dos dados dos bens.
O erro indica arquivo extensão .tmp no qual são apresentados detalhes do erro. A mensagem 21027 é genérica e pode estar associada a várias ocorrências. Quando não identificar motivo da ocorrência, providenciar a geração das informações e encaminhar para a equipe de suporte.

Exemplo da ocorrência ao importar o bem:

dcf727-15800a.jpg

O arquivo c:\temp\fas15800-62341923.tmp apresenta detalhes da inconsistência, no exemplo o erro
17929 - Existe mais de uma movimentação na mesma data:

dcf727-15800b.jpg

É regra de negócio do produto não permitir o registro de movimento em mesma data. A ocorrência está relacionada as informações incluídas no arquivo de importação Bens, informações das sequencias 100 e 470:

No arquivo Bens nos respectivos campos foi informada a mesma data. A regra de negócio do Sistema determina que a Data Movimento de baixa do bem deve ser maior que a Data Aquisição.

Exemplo da linha com erro:
"1 "1" "104" 10903 4 "Partes 1" "" 1 "Anual" 30/11/10 "001" "" "" "" "" "" "" "" "" 10000 "" "" ? "vr. nf. 1" "" "" ? ? 0 "" "" ? ? 0 "" "" ? ? 0 16014 0 0 ? ? "" "" 30/11/10 100 ? ? "2" no no no 0 0 0 0 no 0 0 0"

Neste arquivo de exemplo consta a data 30/11/10 tanto para aquisição como para movimento baixa. Ao ajustar  a data de movimento baixa para 01/12/10, por exemplo, o erro não será mais apresentado.


Exemplo da linha após ajuste:

"1 "1" "104" 10903 4 "Partes 1" "" 1 "Anual" 30/11/10 "001" "" "" "" "" "" "" "" "" 10000 "" "" ? "vr. nf. 1" "" "" ? ? 0 "" "" ? ? 0 "" "" ? ? 0 16014 0 0 ? ? "" "" 01/12/10 100 ? ? "2" no no no 0 0 0 0 no 0 0 0"

Saiba Mais
Cross Segmentos - Linha Datasul - FAS - Ocorreu o erro 15800 no processo executado no Ativo Fixo

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _