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RH - Linha Protheus - MEU RH - O que fazer quando as Solicitações não seguem os Níveis ou Fluxo de aprovação desejado

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Dúvida
O que fazer quando as Solicitações não seguem os Níveis ou Fluxo de aprovação desejado?

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Meu RH – todas as versões

Causa
Esse erro normalmente ocorre quando é efetuado alguma alteração indevida no cadastro de Departamento, principalmente quando o Departamento alterado tem Solicitações Pendentes de aprovação.

Nessa situação a maior ocorrência é que a Chave de busca (QB_KEYINI) do cadastro do Departamento está errada ou repetida para mais de um Departamento, quando esse código está repedido o Sistema se perde e pode demonstrar Solicitações ou alertas de outro Departamento.

Solução
Antes de corrigir é necessário fazer uma análise, então acesse o módulo "07 - SIGAGPE" e busque no menu as opções "Consultas > Cadastros > Genéricos", na opção de pesquisa busque pela SQB e verifique se não há mais de um Departamento com o mesmo código de Chave de busca (QB_KEYINI) ou se existem Departamentos com esse código errado ou vazio/em branco.

Essa opção também está disponível no cadastro do Departamento, porém terá que visualizar todos os cadastros um de cada vez.






Segue um modelo de como esse código é gerado:
mceclip0.png

Siga os passos abaixo caso haja um ou mais Departamentos com a Chave de busca (QB_KEYINI) em uma das situações informadas acima:

1º PASSO: Atualize o ambiente de acordo com a sua release do Protheus, recentemente foram publicados diversos ajustes e melhorias nesse processo:
MP - GPE - Pacote de acumulado do RH no Portal de Cliente
MP - MEU RH - Onde baixo a versão mais recente e como atualizar os arquivos do Portal Meu RH?


2º PASSO: É obrigatório aprovar ou rejeitar todas Solicitações Pendentes (Status 1-EM APROVAÇÃO ou 4- EFETIVAÇÃO RH), de modo que não fique nada Pendente na rotina de "Efetivar Solicitação do Portal (TCFA040)".

Você pode seguir os passos do artigo abaixo caso tenha alguma Solicitação alocada no Aprovador errado:
MP - MEU RH - Como substituir um Aprovador de solicitações pendentes? 

Observação: A rotina "Efetivar Solicitação do Portal (TCFA040)" está disponível em vários módulos, porém, cada um demonstrará as Solicitações que lhe forem pertinentes, por exemplo, no módulo "16 - SIGAPON" você verá as Solicitações de marcação de ponto e no módulo "07 - SIGAGPE" você verá as Solicitações de Férias.

mceclip2.png

3º PASSO: Após a finalização de todas as Solicitações, tente alterar a matrícula aprovadora de algum Departamento, apontando para outro aprovador. Caso ainda existam Solicitações Pendentes, o sistema gerará uma mensagem como validação. Isto servirá como uma certificação de que não há nenhuma Solicitação Pendente;

4º PASSO: Certificando-se de que não tenha nenhuma Solicitação Pendente, acesse o Cadastro de todos os Departamento que precisarão refazer o campo de Chave de Busca - QB_KEYINI, com isso, será necessário deletar todos os campos, menos a descrição, e salvar.

Importante: Realize este processo para todos os Departamentos envolvidos, os quais precisarão ser refeito o código de Chave de Busca no campo QB_KEYINI.

5º PASSO: Por fim, recadastre todos os Departamentos novamente, tendo como início o Departamento do topo da hierarquia, até o mais inferior, para que seja recarregada as informações do campo Chave de busca (QB_KEYINI) sem duplicação.

Saiba Mais
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