Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA038 - Validação do HELP "MA280DTFEC" ao processar o Fechamento de Estoque

Durante a etapa final do processo "Virada de Saldos" no Protheus, ocorre o erro HELP MA280DTFEC, causado por tentativa de usar uma data já registrada nas tabelas SB9, SBJ, SBK ou no parâmetro MV_ULMES. Isso ocorre por manipulação indevida do parâmetro ou inconsistências de atualização. A solução envolve verificar esses parâmetros e tabelas, analisar registros com datas conflitantes e, se necessário, reabrir o período de estoque com suporte técnico para corrigir dados e evitar erros futuros.

time.png Tempo aproximado para leitura: 00:03:00 min

 

Ocorrência

Durante o processamento da ultima etapa do acompanha custos "Virada de Saldos", ocorre o seguinte problema em tela: HELP MA280DTFEC:

MA280DTFEC.png

 

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.


Causa 

Este help está relacionado a alguma data posterior a data de fechamento ou bloqueio, que você está tentando processar. A mensagem é exibida porque o Protheus está tentado realizar a Virada de Saldos com a mesma data que já está gravada nas tabelas SB9, SBJ e SBK e/ou no parâmetro MV_ULMES. 

Isso geralmente ocorre, devido a manipulação indevida no parametro MV_ULMES, que não deve ser feita, pois esse parâmetro é "Exclusivo" para o Fechamento, ou caso o ambiente esteja desatualizado, em decorrências de queda de conexão ou serviços, a jornada pode já ter gravado os dados nas tabelas físicas, mas não ter atualizado o status das tabelas de log D3X, D3Y e D3W.

 


Solução

 - 1 - Verificar o parâmetro MV_ULMES para analisar se é a data que está apresentando no último fechamento do estoque. Verifique também o parâmetro MV_DBLQMOV que frequentemente deve conter a data do último fechamento.

 

 - 2 -  Verificar em suas tabelas SB9, SBJ e SBK se possui algum registro com data igual ou posterior do fechamento em questão.

Por exemplo: fazer uma consulta em seu banco de dados conforme o exemplo abaixo:
➣ Tabela SB9  - SELECT MAX(B9_DATA) FROM SB9T10 WHERE D_E_L_E_T_= '
Assim, irá retornar o valor maior do campo B9_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

➣ Tabela SBJ - SELECT MAX(BJ_DATA) FROM SBJT10 WHERE D_E_L_E_T_= '
Retornará o valor maior do campo BJ_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

➣ Tabela SBK - SELECT MAX(BK_DATA) FROM SBKT10 WHERE D_E_L_E_T_= '
Pois irá retornar o valor maior do campo BK_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

 - 3 - Caso haja o diagnóstico de que realmente existem registros nas tabelas de Saldos Iniciais com data igual ou posterior à data ao qual está precisando fazer a Virada de Saldos, é recomendável uma análise interna para melhor entendimento (se já houve de fato uma virada de saldos), e se houve, se foi de forma indevida, avaliar a possibilidade de reabertura do período de estoque, para isso é necessário o acompanhamento de um analista in loco, ou seu time de T.I, para ajustes devidos nas tabelas de logs D3X,D3Y,D3W no parametro MV_ULMES e dados da SB9/SBJ/SBK.

 

 - 4 - Caso identificada alguma inconsistência processual ou nos dados durante o fechamento, então é necessário cancelar o fechamento em aberto, inconsistente, e refazer o fechamento do início, evitando o mesmo HELP ou  Help MA280DATA.

 

 - 5 - Caso mesmo assim persista o incidente, revisar também esse link da FAQ com instruções para analisar as tabelas envolvidas. Observe que há necessidade de apoio de Analista Especialista de Campo para ajustes nas tabelas envolvidas no processamento. Geralmente esse tipo de situação ocorre devido manipulação direta nas tabelas

 

Saiba mais:

SIGAEST - MATA038 - HELP MA280DTFEC

SIGAEST - Quais os possíveis impactos da Reabertura de Estoque?

SIGAEST - Erro na chamada do processo em rotinas de Processamento

Clique aqui e veja mais artigos sobre Virada de Saldos no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _