Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro Progress 6087 na geração de gráficos

time.png Tempo aproximado para leitura: 00:02:28 min

Ocorrência
Na geração de gráficos a partir de qualquer programa que possua esta funcionalidade ocorre o erro O controle Activex especificado não é registrado ou o arquivo .ocx foi copiado para outro diretório.
Erro ocorreu na procedure: control_load utp/wutapi011.w (6087).

Ambiente
Framework - Framework (Linha Datasul) - Básico (BTB) - Todas as versões

Causa
A geração de gráficos no Datasul utiliza o programa utp/wutapi011.w que por sua vez utiliza o OCX - OLE Control Extension chartfx, sendo os erros acima uma consequência da falta destas instalações na estação.

Solução
Nas estações onde o erro ocorre, será necessário registrar as DLL - Dynamic-Link Library do OCX, conforme procedimentos abaixo:

1. Copie os arquivos abaixo contidos no diretório interfac\chartfx para o diretório C:\Windows\System32, no caso de Windows 32 bits ou C:\Windows\SysWOW64, no caso de Windows 64 bits:
annotation.dll

borders.dll
chartfx.clientserver.annotation.dll
chartfx.clientserver.borders.dll
chartfx.clientserver.core.dll
chartfx.clientserver.data.dll
core.dll
data.dll

2. Abra o Prompt de comando como Administrador, conforme arquitetura 32 bits ou 64 bits.

3. Execute os comandos abaixo, para registrar as DLL, informando o diretório do Windows conforme arquitetura 32 bits ou 64 bits:
regsvr32.exe Diretório-Windows\annotation.dll
regsvr32.exe Diretório-Windows\borders.dll
regsvr32.exe Diretório-Windows\chartfx.clientserver.annotation.dll
regsvr32.exe Diretório-Windows\chartfx.clientserver.borders.dll
regsvr32.exe Diretório-Windows\chartfx.clientserver.core.dll
regsvr32.exe Diretório-Windows\chartfx.clientserver.data.dll
regsvr32.exe Diretório-Windows\core.dll
regsvr32.exe Diretório-Windows\data.dll


4. Após estas operações, efetue novo login no Datasul.

Os procedimentos devem ser realizados em todas as estações que irão emitir o gráfico em questão. Para que seja feito o registro corretamente, o usuário de rede que efetuar o procedimento deve ser o administrador da máquina.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

1 Comentários

  • Avatar
    ROBSON SOUSA

    A bat não está funcionando, ao adicionar o comando pause no fim há vários registros de erro na execução.

    1
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _