Ocorrência
Após a atualização de ambiente, o sistema está apresentado o erro indicando: "Tempo limite da solicitação de bloqueio excedido".
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Todas as versões.
Causa
A ocorrência está ligada a inconsistências de comunicação entre o Dbaccess e a biblioteca DBAPI.DLL.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Recomendamos que adicione as chaves UseLockInDB=0 e LockTimeout=0 no arquivo de configuração do DBAccess (dbaccess.ini) e reinicie o serviço. Segue exemplo de uso das chaves:
[GENERAL]
UseLockInDB=0
LockTimeout=0
Caso persista, realize o mesmo procedimento utilizando o LockTimeout=1000
Documentação da Chave: Melhoria - Novo parâmetro de time-out para MSSQL
Após a aplicação das chaves, reinicie seu DBAccess, utilize-o normalmente e nos reporte se o problema reportado foi sanado.
2. O arquivo DBAPI.DLL precisa estar atualizado, veja como proceder:
O dbaccess e o appserver são 64 bits?
Se forem, é necessário copiar o arquivo dbapi64.dll do dbaccess (Baixar do portal do cliente) para a pasta do Appserver (Todos Slaves) e renomeá-lo para dbapi.dll. Apos o procedimento realizar os devidos testes.
Documentação: MP-FRAME-Arquivo-dbapi-dll-do-DBAccess-no-AppServer
0 Comentários