Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Tempo limite da solicitação de bloqueio excedido

Ocorrência

Após a atualização de ambiente, o sistema está apresentado o erro indicando: "Tempo limite da solicitação de bloqueio excedido".

 

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Todas as versões.


Causa

A ocorrência está ligada a inconsistências de comunicação entre o Dbaccess e a biblioteca DBAPI.DLL.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Recomendamos que adicione as chaves UseLockInDB=0 e LockTimeout=0 no arquivo de configuração do DBAccess (dbaccess.ini) e reinicie o serviço. Segue exemplo de uso das chaves:

[GENERAL]
UseLockInDB=0
LockTimeout=0

Caso persista, realize o mesmo procedimento utilizando o LockTimeout=1000

Documentação da Chave: Melhoria - Novo parâmetro de time-out para MSSQL


Após a aplicação das chaves, reinicie seu DBAccess, utilize-o normalmente e nos reporte se o problema reportado foi sanado.

2. O arquivo DBAPI.DLL precisa estar atualizado, veja como proceder:

O dbaccess e o appserver são 64 bits?

Se forem, é necessário copiar o arquivo dbapi64.dll do dbaccess (Baixar do portal do cliente) para a pasta do Appserver (Todos Slaves) e renomeá-lo para dbapi.dll. Apos o procedimento realizar os devidos testes.

Documentação: MP-FRAME-Arquivo-dbapi-dll-do-DBAccess-no-AppServer

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _