Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - MDT - eSocial - S-2240 - Ao efetuar o cadastro de um risco, o campo “Qtd. Agente” (TN0_QTAGEN) está arredondando o valor que foi cadastrado

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

No módulo Medicina e Segurança do Trabalho, ao efetuar o cadastro de um risco pela rotina MDTA180, o campo “Qtd. Agente” (TN0_QTAGEN) está arredondando o valor que foi cadastrado

Ambiente
TOTVS RH (Linha Protheus) - Medicina e Segurança do Trabalho - Todas as versões

Causa
Esse incidente ocorre, pois o campo TN0_QTAGEN foi alterado para 4 casas decimais conforme validações do eSocial, nesse caso o X3_DECIMAL ficou com 3 casas decimais onde deveria estar com 4.

Solução
1. Acessar o módulo Configurador (SIGACFG).

2. Acessar Base de Dados\Dicionário\Base de Dados, e no dicionário de dados buscar pela tabela TN0 / TN1 / TLK.

mceclip0.png

3. Editar a tabela e buscar pelo campo TN0_QTAGEN / TN1_DEINTE / TN1_ATEINT / TLK_DEQTDE.

mceclip1.png

4. Alterar o campo e trocar o valor de Decimal de 3 para 4, salvar e confirmar a tela.

mceclip2.png

5. Após alterar todos os campos, clicar no ícone de atualizar, para gravar as alterações na base de dados.


mceclip4.png

Documentação Completa: https://tdn.totvs.com/x/laqcHQ

Saiba Mais
Artigos Medicina e Segurança do Trabalho
Artigos eSocial SST

Assistente Virtual Carolina

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _