Ocorrência
O que fazer quando gera o Help A410UNIDIF ou Ajuda: A410UNIDIF no Faturamento?
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)- SIGAFAT - A partir da release 11.80.
Causa
Esse incidente ocorre, devido a inconsistência nas configurações da Base de Dados. Diferenças de Tamanho e Casas Decimais entre os campos das Tabelas utilizadas no processo e no recálculo. Pois quando o sistema faz um cálculo ele vai passar o valor de um campo X (C6_PRCVEN, por exemplo) por vários outros campos, e se não estiver padronizado, as últimas casas decimais serão perdidas em alguma das tabelas, impactando no valor final considerado e levado para o campo de destino.
Solução
Verifique se os campos de quantidade e valor das tabelas SC6, SD1 e SB6 estão com a quantidade de decimais iguais, conforme a documentação: FAT0068_Aumento_de_Casas_Decimais_no_ambiente_Faturamento_SIGAFAT
Todos os campos de quantidade devem ficar iguais entre eles, assim como todos os campo de valor também devem ter o mesmo tamanho entre eles.
Após ajustar os campos, verifique a possibilidade de executar algumas rotinas de recálculos disponibilizados pelo sistema, que podem ajustar os campos que possuem dados incorretos:
- FATURAMENTO > Miscelanea > Ajustes > Refazer Acumulados (MATA215)
- FATURAMENTO > Miscelanea > Ajustes > Refazer Poder de Terceiros (MATA216)
- FINANCEIRO > Miscelanea > Recalculos > Refaz Dados Clientes e Fornecedores (FINA410)
- ESTOQUE/CUSTOS > Miscelanea > Processamentos > Refaz Saldos (MATA300)
Saiba mais sobre outros Helps no pedido:
0 Comentários