Ocorrência
O que fazer quando gera o Help A410UNIDIF ou Ajuda: A410UNIDIF no Faturamento?
Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - A partir da release 11.80.
Causa
Esse incidente ocorre devido a inconsistência nas configurações da Base de Dados. Diferenças de Tamanho e Casas Decimais entre os campos das Tabelas utilizadas no processo e no recálculo.
Pois quando o sistema faz o cálculo do valor de um campo X (C6_PRCVEN, por exemplo), ele utiliza vários outros campos no cálculo, e se não estiverem padronizados, as últimas casas decimais serão perdidas em alguma das tabelas, impactando no valor final considerado e levado para o campo de destino.
Solução
Verifique se os campos de quantidade e valor das tabelas SC6, SD1 e SB6 estão com a quantidade de decimais iguais, conforme a documentação:
Para garantir que todos os campos relacionados estejam padronizados, utilize os Grupos de campos Numéricos. Assim todos os campos de quantidade ficarão com as mesmas configurações, assim como todos os campo de valor dependendo do Grupo que utilizar para o ajuste.
Após ajustar os campos, verifique a possibilidade de executar algumas rotinas de recálculos disponibilizados pelo sistema, que podem ajustar os campos que possuem dados incorretos:
- FATURAMENTO > Miscelanea > Ajustes > Refazer Acumulados (MATA215)
- FATURAMENTO > Miscelanea > Ajustes > Refazer Poder de Terceiros (MATA216)
- FINANCEIRO > Miscelanea > Recalculos > Refaz Dados Clientes e Fornecedores (FINA410)
- ESTOQUE/CUSTOS > Miscelanea > Processamentos > Refaz Saldos (MATA300)
Saiba mais sobre outros Helps no pedido:
0 Comentários