Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - Faturamento (SIGAFAT) - Bloqueio na Tabela SB2

Ocorrência

Ao incluir um pedido de vendas (MATA410), liberar o pedido (MATA440) ou Faturar o pedido de venda (MATA461), onde mais de um usuário esteja manipulando o mesmo produto é gerado um travamento na tabela SB2:



Ambiente

Cross Segmentos-TOTVS Backoffice (Linha Protheus)-Faturamento (SIGAFAT)-  a partir da versão 12.

Causa

No passado a liberação do produto dentro dos processos de pedido de compra e venda, o geração de documento de entrada ou documento de saída, era efetuado por item e agora passou a ser efetuado por documento, causando o travamento na SB2.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Verifique a possibilidade de o uso dos pontos de entradas:

MT103TRVhttp://tdn.totvs.com/pages/releaseview.action?pageId=45220976 ;

MT410TRV - http://tdn.totvs.com/pages/releaseview.action?pageId=187531533;

M461TRVhttp://tdn.totvs.com/display/public/PROT/M461TRV+-+Libera+a+trava+dos+registros+da+tabela+SB2  ;

2. Utitlize o parâmetro MV_FATTRAV (http://tdn.totvs.com/pages/releaseview.action?pageId=233753699) igual a 4;

3. Dentro da geração da nota de saída, deixe os parâmetros MV_GNRENF = .F. (Ver DOC0033_Bloqueio_Pedido_de_Venda_x_Tela_GNRE_Documento_de_Saída) e MV_FISFRAS=.F. (Ver documento http://tdn.totvs.com/pages/releaseview.action?pageId=110431290);

4. Verificar se o mata120 está desatualizado, caso esteja, solicite a equipe de suporte um pacote mais atualizado de acordo com a sua versão;

5. Caso os itens acima não auxiliem no problema de travamento, encaminhe o log profiler e o trace do dbacess para a avaliação da equipe de suporte, em caso de dúvida para extração dos logs, segue documentações:

Log Profiler -MP-FAT-Como-habilitar-e-gerar-o-LogProfiler-para-avaliação-de-desempenho-

Dbtrace - MP-SIGACOM-Como-gerar-o-Log-DbTrace-para-monitorar-baixa-performance-para-rotinas-ADVPL

Maiores informações sobre bloqueios de registros podem ser obtidos através da FAQ: FAT0241 O registro encontra-se Bloqueado por outro usuário

Obs: Dentro do processo de Faturamento, uma forma para trabalhar o uso da tabela SB2 e evitar seu travamento é efetuar a atualização do estoque posterior a geração da nota com a opção de atualização de estoque tardia através de JOB, maiores informações, acesse: MP - FAT - Atualização de Estoque tardia na geração da NF de Saída MV_NFS_JOB 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _