Ocorrência
Após migração ou com contratos já migrados, ao visualizar, alterar ou tentar excluir a medição , apresenta o help Usuário sem direitos sobre a transação selecionada.
Entre em contato com o gestor do contrato
Ambiente
Microsiga Protheus – Gestão de Contratos – A partir da versão 12
Causa
1 - Uma das possibilidades da mensagem exibida trata-se de contratos que foram migrados e vieram sem o preenchimento do campo CND_FILCTR .
2 - Pode ocorrer também devido ao compartilhamento das tabelas do Gestão de Contrato que devem seguir o mesmo padrão.
3 - Outra Possibilidade a Tabela CPD para o contrato correspondente estar deletada.
4 - Uma analise que pode ser realizada no ambiente, se o contrato foi cadastrado com controle de acesso ativado (CN9_VLDCTR = Sim), é se as tabelas CNN e CNO estão preenchidas corretamente com as informações do contrato e no que tange a acessos dos usuários.
Solução
Para solucionar essa ocorrência, realize o seguinte passo:
1. Verifique o conteúdo do campo CND_FILCTR, se o mesmo estiver em branco é necessário efetuar o preenchimento do campo, cuja alteração deve ser efetuada com analista que tenha conhecimentos em Manipulação de Base;
2. Verifique o compartilhamento das tabelas, conforme tdn abaixo:
Compartilhamento de Tabelas - GCT
3. Recuperar o Registro deletado da tabela CPD correspondente ao contrato.
4. Se o contrato foi cadastrado com controle de acesso ativado (CN9_VLDCTR = Sim), o mesmo deve possui registro principalmente na tabela CNN com os vínculos com o usuário e o código de transação contido na tabela CNO, e também os registro da tabela CNO, conforme informações do artigo: Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Controle de Acesso ao contrato no Gestão de Contratos. Caso necessário deve-se realizar a manutenção na base de dados.
Saiba Mais:
MP - SIGAGCT - Controle de Acesso ao contrato no Gestão de Contratos
Artigos Materiais - Gestão de Contratos - (SIGAGCT)
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