Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Framework RM - BD - Cannot load an IDAPI service library. File SQLORA8.DLL

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Erro ao tentar conectar o BDE ao Banco de dados:
Cannot load an IDAPI service library. File SQLORA8.DLL

Ambiente
Framework - Framework (Linha RM) - Banco de Dados - Todas as versões

Causa
Este erro ocorre em alias do tipo Oracle, quando o BDE não consegue carregar a DLL SQLORA8.DLL

Solução
Será necessário realizar o seguinte procedimento:

  1. Renomeie o diretório IDAPI, caso exista em c:;
  2. Remova o BDE pelo painel de controle ou execute o SETUP de instalação e marque a opção remover;
  3. Delete a pasta BDE que fica em: C:\Arquivos de programas\Arquivos comuns\Borland Shared\BDE;
  4. Reinicie a estação de trabalho;
  5. Instale o BDE novamente;
  6. Dê privilégios ao usuário de escrita e gravação na pasta deste arquivo.
  7. Volte o nome da pasta para IDAPI.

Importante
Caso a inconsistência persista, favor verificar a instalação do Client do Oracle conforme artigo abaixo: Framework - Framework RM - BD - Passos Instalação do Client 32 e 64 bits do Oracle na mesma máquina

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    ALISSON CAVALCANTI GALVÃO

    Tive um erro desse nas mãos e essa solução não atendeu. Ocorreu que a string path em variáveis de ambiente apagou os registros do oracle x86 e x64.

    Foi só recolocar a string e voltou a funcionar.

    -1
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _