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Framework - Linha RM - Frame - Erro TimeOut ao logar no RM Portal

time.png Tempo aproximado para leitura: 00:04:20 min

 

Ocorrência
Ao logar no RM Portal Corpore.Net ocorre erro de TimeOut

 

Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM

 

Causa
Falta de licença do portal ou parametrização incorreta

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Acesse o Totvs License Monitor;
  2. Avalie se existe licença para o RM Portal, a licença é a 4001 (Totvs I);
  3. No IIS clique com o botão direito sobre o Default Web Site;
  4. Em Gerenciar Site selecione Configurações Avançadas;
  5. Aumente o Tempo Limite de Conexão para '120', por exemplo:
  6. Ainda no IIS, dentro de Default Web Site selecione o aplicativo Corpore.Net;
  7. Abra a opção Estado da Sessão:
  8. Aumente o Limite de Tempo para '120', por exemplo:


  9. Alterar configuração no arquivo web.config (localizado na pasta C:\totvs\CorporeRM\Corpore.Net).
  10. Localizar as tags abaixo e alterar o valor para, por exemplo, '120':

    <forms name="RMAuthForm" loginUrl="~/Login.aspx" timeout="22" protection="Encryption" path="/" slidingExpiration="true" />
    <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20"/>

    Alterar o valor da tag abaixo para '1000000':
    <httpRuntime requestValidationMode="2.0" maxRequestLength="100000"/>

    para:
    <httpRuntime requestValidationMode="2.0" maxRequestLength="1000000"/>

  11. Acesse o Sistema;
  12. Selecione a aba Ambiente;
  13. Nos Parâmetros Globais na aba Configurações Publicas altere o tempo de espera para "30", por exemplo.
  14. Após realizar as configurações, faz-se necessário reiniciar o serviço do IIS e do Host e efetuar os teste.
  15. No RM acesse o menu Parâmetros Globais e avalie se o endereço na URL de acesso ao RM Portal está preenchida corretamente.

Importante
Desativar Firewall e antivírus e refazer os testes localmente no Servidor de Portal (as diretivas de segurança podem estar derrubando o conexão do RM Portal). Caso o erro não ocorra, poderá ativar o antivírus novamente e criar uma exceção para execução do serviço do Host.

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