Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha RM - Frame - Erro violação de acesso no endereço

Framework - Linha RM - Frame - Erro violação de acesso no endereço

time.png Tempo aproximado para leitura: 00:04:10 min

Ocorrência

Ao acessar qualquer aplicativo Delphi ocorre o erro:

Violação de acesso no endereço 00923379 no módulo 'RMLiber.exe'
Leitura do endereço 0000008B.



Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM


Causa
Esse erro pode ocorrer devido à inconsistência no ambiente, versão desatualizada do .Net Framework ou inconsistência durante a instalação do produto RM.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Desinstale a  Biblioteca RM através do Painel de Controle; 
  2. Atualize a versão do .Net Framework para 4.8 ou superior. Para mais detalhes sobre a versão mínima do .Net Framework para a versão utilizada, consulte o documento de Portabilidade do Sistema;
  3. Instale o BDE 64 bits. Para informações sobre a instalação e configuração do BDE Administrator acesse os links abaixo:
    BDE - Instalação e Configuração SQL
    Framework - Framework RM - BD - BDE Instalação e Configuração ORACLE
    Instalação BDE em ambiente 64 bits

  4. Instale a Biblioteca RM. Abaixo seguem os passos para reinstalação da Biblioteca RM: 
     
    4.1 - Remova a Biblioteca RM através do Adicionar e Remover Programas do Windows;
    4.2 - Acesse o diretório C:\totvs\CorporeRM e apague as pastas RM.Net e API;
    4.3 - Apague o diretório C:\totvs;
    4.4 - Atualize o Windows Installer;
    4.5 - Avalie se a versão do .Net Framework instalada é compatível com a sua versão do RM, conforme documento de portabilidade. Por exemplo, para utilizar a versão 12.1.2302 é necessário que a versão do .Net Framework seja 4.8 ou superior. Mais detalhes no link: Determinar versão do Framework 
    4.6 - Instale a versão correta do Visual C++ compatível com seu sistema operacional. Segue o link da versão correta do Visual C++ para download: 

    Visual C++

    Importante:
    Realize a instalação da versão compatível com a sua arquitetura, 32 ou 64 bits, pois o instalador não realiza essa validação.

    4.7 -
    Desative o UAC - Controle de conta de usuário;
    4.8 - Desative todos os Firewalls;
    4.9 - Desative o antivírus para realizar a instalação;
    4.10 - Reinicie a máquina;
    4.11 - Ao acessar novamente o Windows (após a reinicialização), deverá ser realizada novamente a instalação do produto, porém, ao instalar clique com o botão direito do mouse em cima do instalador e selecione a opção: instalar como administrador;
    4.12 - Faça a instalação seguindo a ordem;


    BibliotecaRM - 12.1.2310.msi
    Patch12.1.2310.114.zip

    Saiba mais 
    Para mais informações sobre como instalar a biblioteca rm, consulte o artigo: Framework - Linha RM - Frame - Como instalar a biblioteca RM
    Para mais informações sobre como instalar o patch, consulte o artigo: Framework - Linha RM - Frame - Como realizar atualização de patch

  5. Acesse o sistema novamente para realizar os testes. 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _