Ocorrência
Ao executar rotinas de processamento (Ex. Saldo Atual, Virada de Saldos, Recalculo do Custo Médio e etc) é exibida a mensagem "Erro na Chamada do Processo". Como proceder diante deste erro?
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Esta mensagem é exibida na tela quando utilizamos "Stored Procedures" da rotina de processamento e por algum motivo a Procedure gera uma inconsistência em sua execução.
Solução
Antes de seguirmos com as alternativas, é importante certificar-se de que a base esteja atualizada. Desta forma, para atualizar o pacote acumulado do Estoque/Custos, selecione a sua release e clique aqui
Obs: Sempre que aplicar um pacote ou fonte, efetue primeiramente em ambiente de homologação. Em caso de sucesso na aplicação, efetue no ambiente de produção.
Partindo da premissa que o acumulado do Estoque/Custos esteja atualizado, siga os passos abaixo:
1° (Se o problema for na rotina Refaz Acumulados - MATA215, pular este passo) - Através do modulo "Configurador (SIGACFG)" verifique se o conteúdo do parâmetro MV_CUSTEXC está configurado como "Compartilhado" conforme abaixo.
2° - Abra o arquivo "error.log" e verifique se houve algum incidente no processamento da rotina.
Importante: Antes de executar a rotina habilite a chave "TRACESTACK=1" no seu arquivo appserver.ini (Para informações maiores informações clique aqui).
3° - Abra o dbAccess Monitor de seu ambiente e execute os procedimentos abaixo:
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- Abra o dbAccess Monitor, clique na aba "Mensagem" e aperte o botão "LIMPAR";
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- Execute a rotina de Processamento e deixe a mensagem "Erro na Chamada do Processo" ser exibida na tela. Retorne ao dbAccess Monitor e verifique na aba mensagem a existência de algum texto de não-conformidade gerado pela rotina, caso exista solicite apoio a sua equipe de Tecnologia da Informação para avaliação.
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4° - Via SIGACFG:
- Desinstale a Stored Procedure XX (Sendo XX o código da Procedure) via configurador.
- Faça um backup e delete a Stored Procedure da pasta \SYSTEM.
- Reinicie o TOPConnect.
- Cole a Stored Procedure na pasta \SYSTEM.
- Instale a Stored Procedure via configurador.
Caso nenhuma destas alternativas resolva, acione a equipe de Suporte Técnico evidenciando cada etapa deste documento e retorne na abertura do ticket os arquivos console.log, console.bak, error.log, appserver.ini, dbconsole.log, dbaccess.log, cópia da tabela SX6 e o inspetor de objetos.
Para clientes que já utilizam o Novo Gestor de Procedures
Para cliente com o novo Gestor de Procedures, é imprescindível que o mesmo esteja em sua última versão (1.4.3). Para obtê-lo, basta baixar clicando aqui.
Posteriormente, reinstale a Stored Procedure causadora do erro e tente executar a rotina novamente.
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