Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - PON - Cadastro de Exceções por Período quando tem colaboradores afastados e de férias

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
No módulo do Ponto Eletrônico ao cadastrar um exceção por período filtrando por centro de custo, o sistema aplica a exceção para todos os funcionários daquele centro de custo. Porém, essa exceção é incluída também para os funcionários que estão afastados ou de Férias, gerando falta ou apontamento indevido.

Ambiente
TOTVS RH - (Linha Protheus) - Ponto Eletrônico - Todas as versões 

Causa 
Esse incidente ocorre, pois a parametrização da rotina não havia um campo específico para informar a situação dos funcionários, para assim filtrar e não aplicar para todos.

Solução
Foi criado um novo campo Situações (P2_SITFUN) no cadastro de exceções para selecionar as situações em que a exceção será aplicada. Em Atualizações> Cadastro de Funcionários> Exceções por Período, exemplo abaixo para um funcionário de férias:

- Funcionário de férias do dia 01/10/2024 à 11/10/2024, realizado o cadastro da exceção por período para os dias 11/10 e 12/10

No novo campo Situações foi selecionada apenas a situação normal, isso indica que a exceção será aplicada apenas para os funcionários com a situação normal.

 

Ao consultar em integrados em Atualizações> Lançamentos> Integrados, é possível verificar que o dia 11/10 foi mantido como férias enquanto que no dia 12/10 (em que o funcionário não está mais de férias) a exceção foi aplicada, sendo alterado o sabado para um dia trabalhado.


Importante: Para a criação do novo campo é necessário executar o UPDDISTR com o pacote diferencial da Expedição Contínua do RH. Para mais informações referente ao campo clique aqui



Saiba mais:
Manual do Ponto Eletrônico
Pacote de Expedição Contínua - Acumulado de RH
RH - Linha Protheus - PON - Como cadastrar Exceção por Período para deixar o dia Não Trabalhado
RH - Linha Protheus - PON - Como tratar feriados municipais no Ponto Eletrônico

 

 

 

 

 

 

 

 

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _