Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ajuste/alteração no tamanho dos campos NUMSEQ
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Protheus Release 12.1.2410 ou Superior.
Causa
Mesmo sendo um campo alfanumérico de 6 posições, o NUMSEQ pode ter suas combinações esgotadas em alguns cenários, resultando em duplicações após o reinício. Nesses casos, pode ser necessário ajustá-lo manualmente para permitir a geração de novos códigos.
Solução
Abaixo seguem alguns pontos de atenção para esse tipo de alteração
-
Campos envolvidos
Caso a numeração tenha por atingir o valor máximo do campo (ZZZZZZ). Os principais campos envolvidos no processo estão listados na documentação:
Campos envolvidos no controle de numeração NUMSEQ
-
Ajuste de Chave @@@SD2
Neste caso, também é necessário realizar um ajuste no controle de numeração, conforme indicado na documentação:
1. Acessar o controle de numeração do configurador
2. Localizar a chave que faz o controle da numeração NUMSEQ; a chave tem o formato SpecialKey + @@@ + SD2 + Código da empresa + 0. Por exemplo, PROD@@@SD2010 (O alias da chave será sempre SD2)
3. Ao localizar a chave, alterar o tamanho e a numeração, conforme novo tamanho de campos NUMSEQ. Por exemplo, se o campo foi alterado de tamanho 6 para 10, deve-se alterar o campo “Tamanho” de 6 para 10 e o campo “Numero” de 003409 para 0034090000.
4. Avaliar o grid Números em uso/Números liberados, e ajustar quaisquer numerações não confirmadas lá também.
-
Mais de um ambiente apontando para o mesmo banco de dados
Se houver mais de um ambiente configurado sem a SpecialKey (ou com {}CheckSpecialKey = 0{}), a sequência pode ser impactada por movimentações da homologação, gerando duplicidades ou saltos na numeração.
Em empresas onde existem mais de um ambiente apontando para o mesmo banco de dados, com chaves {}SpecialKey diferentes{}, podem ocorrer problemas similares, pois o License Server fará o controle paralelo de várias numerações para gravar a mesma tabela.
IMPORTANTE: O sistema agora impede a execução das rotinas se detectar configuração incorreta da {}SpecialKey{}, evitando que o problema se propague. Dados já gravados devem ser ajustados manualmente.
Realizei os ajustes e a Sequência da Numeração ainda estão sendo criadas incorretamente. O que Fazer?
Para esse cenário verificar se é o caso reportado na FAQ abaixo:
SIGAEST - Campos _NUMSEQ repetidos mesmo após apagar lsnumber.val e reiniciar o License Server
Saiba mais:
Descontinuidade do MV_DOCSEQ na Release 12.1.2410
SIGAEST - Campos _NUMSEQ repetidos mesmo após apagar lsnumber.val e reiniciar o License Server
SIGAEST - Erro no calculo do custo _NUMSEQ duplicado
0 Comentários