Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - Importador XML - Help AJUDA TOTAL Valor total inválido


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência


Ao Gerar Documento na rotina do Monitor, sistema gera ocorrência  Help AJUDA TOTAL Valor total inválido, conforme print abaixo.

Obs.: Este erro pode ocorrer quando a inconsistência estiver no valor total, no valor unitário ou na quantidade.


 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Compras - versão 12Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Compras - versão 12

Causa 
O erro em questão ocorre quando a configuração de TAMANHO e/ou DECIMAIS dos campos das tabelas SDS e/ou SDT está divergente da configuração dos campos das tabelas SF1 e SD1 que são suas correspondentes.

Solução
Para solucionar esta ocorrência, abra o módulo SIGACFG e verifique como estão configurados os campos abaixo. Os campos correspondentes precisam ter mesmo tamanho e decimais. Por exemplo, se o campo DS_QUANT tiver tamanho 15 e decimais 4 o campo D1_QUANT também deverá ter. Seguem abaixo os campos correspondentes que devem ser validados.

 

Quantidade

DT_QUANT e D1_QUANT

Valor unitário

DT_VUNIT e D1_VUNIT

Valor total

DT_TOTAL e D1_TOTAL

 

Sendo assim, busque a configuração desses campos e ajuste-os conforme o necessário para que fiquem corretos conforme indicado acima. 

Após realizar os ajustes, é necessário que efetue o procedimento abaixo para reprocessar a nota

  1. Abra a rotina do Monitor, localize e selecione a nota com essa ocorrência, clique em Outras ações, clicar em Excluir
  2. Abra o Reprocessar, vá na aba Excluídos, localize a nota e selecione-a, clicar em Excluir
  3. Com a nota excluída, agora será necessário importá-la manualmente.
  4. Agora vamos importá-la do zero
                               1.Coloque o XML na pasta INN
                               2. Execute as rotinas COLAUTOREAD e depois SCHEDCOMCOL
                               3. A nota irá aparecer no Monitor
                               4. Selecione a nota, e gere documento novamente 

 

O aumento de casas decimais no Protheus é uma questão delicada. Quando realizado sem os devidos critérios, ou não recebe a devida manutenção, pode causar diversas inconsistências.

Por esse motivo a TOTVS Criou os Grupos de Campos Numéricos.

 

IMPORTANTE: Qualquer tratamento relacionado a casas decimais é considerado um desvio do Nativo do Protheus (no qual é padrão o uso de dois dígitos, apenas, para o ambiente Faturamento).
Portanto, é indicado que qualquer alteração neste sentido seja realizado e documentado por um analista in loco (Consultar diretamente seu ESN) para análise pontual de sua base/ seu cenário, e sempre utilizando os Grupos de Campos Numéricos.

 

Saiba Mais:

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _