Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Ocorreu o erro -2 no consumo da licença do programa , este programa será encerrado

time.png Tempo aproximado para leitura: 00:01:15 min

Ocorrência
Após atualização das releases liberadas no dia 01/09/25, passou a ocorrer o erro Ocorreu o erro -2 no consumo da licença do programa , este programa será encerrado na execução de programas via RPW Clássico.

Ambiente
Framework - Framework (Linha Datasul) - Básico (BTB) - Todas as versões

Causa
Após liberação do último patch, passou a ocorrer erro no RPW Clássico quando está configurado 1 Servidor X 1 Usuário.

Solução
Como o RPW Clássico foi descontinuado, não serão feitas correções. Diante disso, orientamos a instalar e utilizar o novo RPW que chamamos de Automação de Tarefas
Em testes internos, identificamos que o problema não ocorre se no cadastro Servidor Execução - bas_servid_exec o campo Servidor estiver com valor maior que 1 (multitarefa). Recomendamos realizar esta configuração como medida paliativa até que migrem para o Automação de Tarefas.

Caso o erro seja exibido já no Automação de Tarefas (Novo RPW), verifique se o processo do Garbage Collector no servidor de aplicação PASOE criado para o Automação de Tarefas está configurado. Esta informação consta como ponto de Atenção no link da documentação para configuração do Automação de Tarefas no Saiba Mais.

Saiba mais
Documentação referente a descontinuidade do RPW Clássico a partir do dia 04/07/2025: Substituição: Feature RPW - TOTVS Linha Datasul.
Documentação para configuração do Automação de Tarefas.
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _