Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA950 - type mismatch on compare on MAPASPF:PROCESSMOV(MAPASPF.PRW)

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao gerar o processo na rotina MATA950, ocorre o erro type mismatch on compare on MAPASPF:PROCESSMOV(MAPASPF.PRW) 07/02/2025 17:20:50 line : 2589

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
 

Causa 
Esse incidente ocorre, pois algum campo esta faltante para geração do processamento.
 

Solução
Solicite ao TI responsável que consulte a QUERY registrada no error.log na STACK da chamada da função para validar os valores gravados nos campos UM e UNMAPA.

Screenshot_1.png

Screenshot_2.png

  1. Verifique no complemento de cadastro do produto se a Unidade de Medida está corretamente informada, pois no erro os dados filtrados po UM e UNMAPA vão estar diferentes:

  2. Ajuste o cadastro do produto, caso seja identificada inconsistência na unidade (exemplo: produto cadastrado sem unidade ou com unidade divergente).

 

Ao processar a rotina MATA950, o sistema pode apresentar o erro:

THREAD ERROR ([00000], nome_do_usuario, XPTO-1) 12/08/2025 17:25:23
type mismatch on compare on MAPASPF:PROCESSMOV(MAPASPF.PRW) 07/02/2025 17:20:50 line : 2589

Esse erro é identificado como um problema de comparação de variáveis durante a execução da rotina.

No fonte, a rotina tenta executar uma comparação (!= ou ==) entre os campos:

  • UM → Unidade de Medida (exemplo: "KG")

  • UNMAPA → Unidade do Mapa

Ocorre inconsistência porque:

  • O campo UM vem como caractere (ex.: "KG")

  • O campo UNMAPA vem numérico (ex.: 0)

Essa diferença de tipos (caractere x numérico) causa o erro de type mismatch.

 

Relacionado:
Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA950/MATR913 - Mapas de Controle de Produtos Químicos - Conceito e Configurações Mínimas
 

Saiba Mais:
Clique aqui e veja mais artigos sobre LEGAIS no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _